create a new system raid on running centos 6.3

Discussion in 'HOWTO-Related Questions' started by coloradosky, Dec 17, 2012.

  1. coloradosky

    coloradosky New Member

    I have a production system that has a failed dmraid for the system disk. I have tried to fail the drive and replace it but it will not rebuild. I would like to move this to a md raid. I have a test system that I have been working on and have not been successful as yet to duplicate and correct this problem.

    test system:
    running centos 6.3 on a single disk.
    created a new md0 raid1 on two other disks that I have installed. ( I used the HOW-TO -------How To Create A RAID1 Setup On An Existing CentOS/RedHat 6.0 System )
    everything worked just fine but when I try to install the grub installed on the raid1 ( md0 ) it is failing with this error:

    root (hd1,0)
    Error 5: Partition table invalid or corrupt

    I have tried this on both disks of the raid1 and get the same error from both.

    Any guidance from this point will be great.


Share This Page