Courier Not Creating Mail directories

Discussion in 'Server Operation' started by eliufoo, Jul 8, 2008.

  1. eliufoo

    eliufoo New Member

    Hi guys,

    I have finished migrating my mail server from using postfix & dovecot to postfix & courier imap using the the following howto (Virtual Users With Postfix, PostfixAdmin, Courier, Mailscanner, ClamAV On CentOS). And I'm using postfixadmin to manage my virtual users.

    I'm now experiancing a problem with users mail dir not been created. I get the following error when loggin to pop3 account using a telnet session.

    maillog

    Please assist.

    regards,
    Elly
     
  2. eliufoo

    eliufoo New Member

    http://www.howtoforge.com/forums/showthread.php?t=10122

    Found a similar thread and made the changes accordinly except for my,

    I'm now receiveing the following error,
    Looking at the /var/log/maillog file, i get the following errors

    courier-pop3 doesn't receive an email since maildrop is failing to deliver the email. And maildrop is failing cause it doesn't see the directory to deliver the email???

    What happening here?
     
    Last edited: Jul 8, 2008
  3. falko

    falko Super Moderator ISPConfig Developer

    Did you send an email first to that account before you tried to fetch emails? Maildir is created automatically when the first email arrives.
     
  4. eliufoo

    eliufoo New Member

    Got it fixed. :)

    It was a typo problem with authmysqlrc file. I found out that, trailing spaces are PROHIBITED and I had plenty of those. See below changes I made. (I will also advise others read authmysqlrc file. my is located in /etc/authlib/authmysqlrc)

    Single space between field & value.

    Also, if you are using maildrop to delivery message to your virtual uses. You might encounter the following error.


    I solved this by changing the ownership of maildroprc.log file from root to vmail.


    Elly

    ----------------------------------------
    Working Towards United States Of Africa
     

Share This Page