Courier installing error in Fedora10

Discussion in 'Installation/Configuration' started by bola, Feb 11, 2009.

  1. bola

    bola New Member

    i have the next error installing courier in my box:
    wget http://prdownloads.sourceforge.net/courier/courier-authlib-0.62.1.tar.bz2
    wget http://prdownloads.sourceforge.net/courier/courier-imap-4.4.1.20080920.tar.bz2
    wget http://prdownloads.sourceforge.net/courier/maildrop-2.0.4.20080726.tar.bz2
    donne
    sudo rpmbuild -ta courier-authlib-0.62.1.tar.bz2
    donne
    cd $HOME/rpm/RPMS/i386
    donne
    sudo rpm -ivh courier-authlib-0.62.1-1.fc10.i386.rpm
    sudo rpm -ivh courier-authlib-devel-0.62.1-1.fc10.i386.rpm
    sudo rpm -ivh courier-authlib-mysql-0.62.1-1.fc10.i386.rpm
    donne
    rpmbuild -ta courier-imap-4.4.1.20080920.tar.bz2
    ERROR:
    checking for courierauthconfig... /usr/local/bin/courierauthconfig
    configure: error: Courier authentication library version 0.61 required.
    error: Bad exit status from /var/tmp/rpm-tmp.5FHz3A (%prep)


    RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.5FHz3A (%prep)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you install all these packages?
    Code:
    yum install ntp httpd mysql-server php php-mysql php-mbstring rpm-build gcc mysql-devel openssl-devel cyrus-sasl-devel pkgconfig zlib-devel phpMyAdmin pcre-devel openldap-devel postgresql-devel expect libtool-ltdl-devel openldap-servers libtool gdbm-devel pam-devel gamin-devel
    Also, is SELinux disabled?
     
  3. bola

    bola New Member

    Package ntp-4.2.4p6-1.fc10.i386 already installed and latest version
    Package httpd-2.2.10-2.i386 already installed and latest version
    Package mysql-server-5.0.67-2.fc10.i386 already installed and latest version
    Package php-5.2.6-5.i386 already installed and latest version
    Package php-mysql-5.2.6-5.i386 already installed and latest version
    Package php-mbstring-5.2.6-5.i386 already installed and latest version
    Package rpm-build-4.6.0-0.rc3.1.fc10.i386 already installed and latest version
    Package gcc-4.3.2-7.i386 already installed and latest version
    Package mysql-devel-5.0.67-2.fc10.i386 already installed and latest version
    Package openssl-devel-0.9.8g-12.fc10.i386 already installed and latest version
    Package cyrus-sasl-devel-2.1.22-19.fc10.i386 already installed and latest version
    Package 1:pkgconfig-0.23-3.fc10.i386 already installed and latest version
    Package zlib-devel-1.2.3-18.fc9.i386 already installed and latest version
    Package pcre-devel-7.8-1.fc10.i386 already installed and latest version
    Package openldap-devel-2.4.12-1.fc10.i386 already installed and latest version
    Package postgresql-devel-8.3.6-1.fc10.i386 already installed and latest version
    Package expect-5.43.0-15.fc10.i386 already installed and latest version
    Package libtool-ltdl-devel-1.5.26-4.fc10.i386 already installed and latest version
    Package openldap-servers-2.4.12-1.fc10.i386 already installed and latest version
    Package libtool-1.5.26-4.fc10.i386 already installed and latest version
    Package gdbm-devel-1.8.0-29.fc10.i386 already installed and latest version
    Package pam-devel-1.0.2-2.fc10.i386 already installed and latest version
    Package gamin-devel-0.1.9-6.fc10.i386 already installed and latest version

    SELINUX=disabled
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. sghazagh

    sghazagh New Member

    did you find a solution for courier-imap compile ?
    I have a same issu and can not build the RPM package?!
     
  6. sghazagh

    sghazagh New Member

    fixed

    Hello guys,
    Just get courier-imap 4.7.0 and build works fine.
     

Share This Page