Courier IMAP Connects but does not recieve

Discussion in 'Server Operation' started by CarbonCopy, Apr 17, 2009.

  1. CarbonCopy

    CarbonCopy New Member

    I followed the guide located here: except for a few places where files were in different places etc. I am now able to authenticate and login, and see my inbox, however, emails don't appear to be going through. I have no idea what to do now. I also found out that I had to use

    ./maildirmake /home/vmail/
    chown -R vmail:vmail /home/vmail/

    If there are files or info you need let me know and I'll post it. I also get a few errors about "Unable to connect to your IMAP server. You may have exceeded the maximum number of connections to this server." (Mozilla Thunderbird on Windows). Anyone of upping the connection limit?

    Last edited: Apr 17, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    Please check your mail log.

    Maildir is created automatically once the first email arrives.

    Which distribution are you using?
  3. CarbonCopy

    CarbonCopy New Member


    Well thanks for letting me know about the maildir being created. I however had to create it because when I logged into IMAP I just got an error about the maildir not existing.

    I am using the most recent version of CentOS 64bit, based off RHEL as you probably know.

    Not sure if it helps, but I just copied 4 emails to my inbox using thunderbird, marked them as unread, then checked my email with and they show up.

    Would I need to setup a mx record or something for imap?


    [root]~ # netstat -tulp
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    tcp        0      0 *:mysql                     *:*                         LISTEN      16965/mysqld
    tcp        0      0 cl-t112-271cl.privated:pop3 *:*                         LISTEN      17163/couriertcpd
    tcp        0      0 cl-t112-271cl.privated:imap *:*                         LISTEN      17564/couriertcpd
    tcp        0      0 cl-t112-271cl.privated:http *:*                         LISTEN      16603/httpd
    tcp        0      0 *:ftp                       *:*                         LISTEN      32568/proftpd: (acc
    tcp        0      0 *:smtp                      *:*                         LISTEN      2258/master
    tcp        0      0 *:ssh                       *:*                         LISTEN      32744/sshd
    And I have ADDRESS set in my imapd file to my server's ip address. Courier imap is installed to /usr/lib/courier-imap/

    And I have SELinux enabled, and would prefer to leave it that way, but if I must I can disable it, also, my /var/log/debug and /var/log/maillog files are empty (I cleared them after I fixed the last problem).
    Last edited: Apr 17, 2009
  4. falko

    falko Super Moderator ISPConfig Developer

    Make sure that the MX records for your domains point to your server.

    You should turn it off, at least until you get everything working (so that we can rule out SELinux as a source of errors). Afterwards you can try to enable it again.
  5. CarbonCopy

    CarbonCopy New Member

    I just got the rest of my server features working, apache, postfix, mysql, etc. I also reinstall courier, and I got it to authenticate against a mysql database properly. Like I had before, I can see emails I manually transfer, AND I receive local mail. Just no emails from the outside.

    SELinux and the native firewall is disabled

    My SQL usertable looks like this:

    email 	            home 	password        passwordcrypt 	 quota
    [email protected] /home/vmail <password_md5>  <password_crypt> 10485760
    Configuration Files:




    Earlier when I tried sending with gmail I received an email a day later saying this:
    DNS Error: DNS server returned answer with no data

    I've reinstall courier since then, but it may still be the problem
  6. tebokkel

    tebokkel New Member

    Assuming is your domain, I just was able to lookup your DNS (A-record x.x.11.102) and (manually) send you an email.
    There was no problem, not with DNS, not with sending the mail.

    Did it arrive?

  7. CarbonCopy

    CarbonCopy New Member

    Yeah, it was a problem with my a record. I just had added it properly. I had @ and I put instead and it works fine. Got your mail.


Share This Page