Courier can't chdir to mail directory

Discussion in 'HOWTO-Related Questions' started by helzer, Aug 31, 2007.

  1. helzer

    helzer New Member

    Hi,

    I'm running Ubuntu 7.04 and followed:
    http://www.howtoforge.com/virtual_users_and_domains_with_postfix_debian_etch

    When the servers start, this is what I get:
    Code:
    ubuntu1 postfix/master[4447]: daemon started -- version 2.3.8, configuration /etc/postfix
    ubuntu1 authdaemond: modules="authmysql", daemons=5
    ubuntu1 authdaemond: Installing libauthmysql
    ubuntu1 authdaemond: Installation complete: authmysql
    
    The user gets authenticated OK from the MySQL database, but then, courier can't get to the mailbox:
    Code:
    ubuntu1 imapd: chdir onthegosystems.local/amir/: No such file or directory
    How do I start to debug this?

    Thanks,
    Helzer
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /home/vmail
    ?
     
  3. helzer

    helzer New Member

    It's empty. I was thinking that there should be something there, created by courier, but there's nothing.

    The directory (/home/vmail) does belong to user vmail (and group vmail).

    Amir
     
  4. falko

    falko Super Moderator ISPConfig Developer

    The ownerships are correct. Normally the directories/mailboxes should be created automatically... :confused:
     
  5. helzer

    helzer New Member

    I'm almost sure it's something I've done, but there's a slight possibility that there's something different in my setup causing the howto to go wrong. My Linux distro is Ubuntu 7.04 and not the original Debian.

    How can I debug this?
    Is there a way to create a more detailed log showing exactly what Courier is doing?

    What I'm thinking is:
    - It's trying to create the directories somewhere else than /home/vmail
    - It's running as a different user and can't create directories in /home/vmail
    - Some switch is missing and courier is simply not trying to create the directories at all.

    But, I don't want to make brute force attempts until it just works. It would be very nice if I find the debug information and be able to understand what's going on there.

    Any thoughts?

    Thanks,
    Helzer
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Please compare your configuration with the one from the tutorial. Maybe you made a typo somewhere.
     
  7. dylanhky

    dylanhky New Member

    Same problems too

    I'm having the same problems too.

    1.I had to manually create the maildir with maildirmake.

    2. I tried sending email between users in the same domain, and setting the transport table to deliver locally. But whenever I send mail.... the mail is delivered to /home/vmail/xxxx.com instead of /home/vmail/xxxx.com/user1 .
     
  8. helzer

    helzer New Member

    I've got this working now on a production server, running the same Ubuntu. A technician set this up with postfix + dovecot. I'll go through the setup and see if there's something unique to Ubuntu that's set any different. Will let you know.

    Amir
     
  9. dylanhky

    dylanhky New Member

    I've fix my problem, there was a typo as falko suggested in the sql query string in /etc/postfix/mysql-virtual_mailboxes.cf.

    Problem solved for me..thanks a lot
     

Share This Page