courier-authlib-mysql not working

Discussion in 'HOWTO-Related Questions' started by countzerocrc, Mar 22, 2009.

  1. countzerocrc

    countzerocrc New Member


    i´m trying to set up virtual domains with postfix etc. (on Ubuntu 8.04)
    But i have a problem with getting courier-authlib-mysql running.

    Packages courier-authlib and courier-authlib-mysql are installed (from sources) but whenever i try to auth via imap i get the following error in my syslog:

    Mar 22 15:22:25 my-servername authdaemond.plain: Unknown module 'authmysql' skipped
    snip authdaemonrc
    authmodulelist="authmysql authpam"
    when i remove authpam here no process is spawned.

    any ideas? tried removing all courier packages and reinstalling but no change.

    authmodulelist="authmysql authpam"
    authmodulelistorig="authcustom authcram authuserdb authldap authpgsql authmysql authpam"
    tried setting version = authdaemond.mysql results in:
    Mar 22 15:38:20 my-servername authdaemond.mysql: exec: No such file or directory

    checked the lib directory:
    ls /usr/lib/courier/authlib/ -la
    total 63
    drwxr-xr-x 2 root root  1024 Mar 15 10:34 .
    drwxr-xr-x 6 root root  1024 Mar 22 15:19 ..
    -rwxr-xr-x 1 root root 15228 Jun  8  2006 authdaemon
    -rwxr-xr-x 1 root root   520 Jun  8  2006 authdaemond
    -rwxr-xr-x 1 root root 43816 Jun  8  2006 authdaemond.plain
    seems like the authdaemond.mysql file is missing. (/me not sure here :confused:)

    any help would be highly appreciated :)
  2. countzerocrc

    countzerocrc New Member

    solved - changed startscript

    problem solved by fixing the startscript of the authd :D

Share This Page