Couldn't load kernel module

Discussion in 'Kernel Questions' started by gregor, May 26, 2007.

  1. gregor

    gregor New Member

    One server has problem. It appears on Suse 10.0 kernel 2.6.13 and Fedora 6 kernels 2.6.18, 2.6.20. Now RH Fedora 6 with kernel 2.6.20. After some days normal working and rebooting depmod couldn't find any module and at startup network (8139too module) couldn't start, xfs partitions (xfs module) couldn't mount. But the worse thing, any modules couldn't be load with "-1 Unknown symbol in module". Seems like module was broken. MB and cable where changed. How to fix this?
    [[email protected] ~]# depmod nf_nat_ftp
    WARNING: Can't read module nf_nat_ftp: No such file or directory
    [[email protected] ~]# modinfo nf_nat_ftp
    modinfo: could not find module nf_nat_ftp
    [[email protected] ~]# depmod /lib/modules/2.6.20-1.2948.fc6/kernel/net/ipv4/netfilter/nf_nat_ftp.ko
    [[email protected] ~]# lsmod | grep ftp
    nf_conntrack_ftp       13761  0
    nf_conntrack           62409  6 iptable_nat,nf_nat,nf_conntrack_irc,nf_conntrack_ftp,xt_state,nf_conntrack_ipv4
    [[email protected] ~]# insmod /lib/modules/2.6.20-1.2948.fc6/kernel/net/ipv4/netfilter/nf_nat_ftp.ko
    [[email protected] ~]# lsmod | grep ftp
    nf_nat_ftp              7489  0
    nf_nat                 21997  2 nf_nat_ftp,iptable_nat
    nf_conntrack_ftp       13761  1 nf_nat_ftp
    nf_conntrack           62409  7 nf_nat_ftp,iptable_nat,nf_nat,nf_conntrack_irc,nf_conntrack_ftp,xt_state,nf_conntrack_ipv4
  2. falko

    falko Super Moderator ISPConfig Developer

    I'm not sure, but maybe you must compile a new kernel so that it "knows" your mainboard.
  3. gregor

    gregor New Member

    Yes, my first desire was it, but now 'depmod -a' filled all /lib/modules/`uname -r`/modules.* and now depmod|modinfo find any modules. Nest step to ask support what is the mainbord with:
    00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE
    Controller (rev 01)
    00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family)
    Serial ATA Storage Controller IDE (rev 01)
    and compile new kernel...

    P.S. Thanks any time for reply!
  4. gregor

    gregor New Member

    Tha problem was not in kernel or mainboard. After rebooting server modules.dep not generating well and become empty!!! That's couldn't be found xfs and 8139too modules. Wich service should generate /lib/modules/`uname -r`/modules.* in RedHat Fedora Core 6?
  5. falko

    falko Super Moderator ISPConfig Developer

    depmod `uname -r`
  6. gregor

    gregor New Member

    Yes it works when server was up, but why files not generated while services start up? And who should do it in FC6?
  7. falko

    falko Super Moderator ISPConfig Developer

    Is SELinux enabled? If so, try to disable it.
  8. gregor

    gregor New Member

    Thank you very much! :) Just what me needed!!!
  9. Isamar Maia

    Isamar Maia New Member

    Didn't work for me

    I have exactly the same problem but this solution didn't work out for me.
    ANy thoughts?

  10. gregor

    gregor New Member

    Try to disable SELinux, should help...
  11. Isamar Maia

    Isamar Maia New Member

    Disabling SELINUX didn't solve the problem

    Disabling SELINUX didn't solve the problem.
    I keep having zero-length modules.dep everytime I run modprobe.

    Any thoughts?

  12. gregor

    gregor New Member

    If you run 'modprobe -a', modules.dep will be filled correct?
  13. Isamar Maia

    Isamar Maia New Member

    modprobe -a doesn't work either

    modprobe -a doesn't work either.

    The workaround I did was to make a chattr +i /lib/modules`uname -r`/modules.dep

    So no process or application can change it at all.

    But I would like to know anyway, if anybody can explain, which piece of the puzzle is missing in this case.

    Maybe it's a bug in module-init-tools package. I'll try to report it as a bug anyway.

    I am using FC6 with module-init-tools-3.3-0.pre1.4.17, the latest one.

  14. falko

    falko Super Moderator ISPConfig Developer

    Did you reboot the system?
  15. Isamar Maia

    Isamar Maia New Member

    zero-length file size for modules.dep

    Yes. I rebooted couple times already and the same behaviour persists.
    Also, I am passing "selinux=0" as kernel parameter inside grub.conf
    and /etc/sysconfig/selinux has selinux disabled.

    I already did a strace also when I call modprobe but nothing apparently
    strange is there.


Share This Page