Couldn't find any host by that name

Discussion in 'Technical' started by giganet, Sep 5, 2007.

  1. giganet

    giganet New Member

    Ubuntu 6.06
    Apache 2
    PostFix
    CourierPOP3
    Courier IMAP
    Bind9
    ISPConfig 2.2.16


    Have got the server accessible BTW VIA web-browser- www.giganetwireless.com

    I have created all email accounts that server this site under ISPConfig.

    Using Thunderbird, if I press "Get Mail' the client connects and authenticates to the server, a cert is presented for acceptance after accpeting the cert the email status is checked- Thunderbird encounters no errors- yet their is never any email it can retrieve.

    There should be mail there however!
    I emailed myself form a Yahoo account yesterday!
    This morning in my Yahoo email account I see the email I sent had bounced back to my Yahoo email account.

    Code:
    <[email protected]>:
    Sorry, I couldn't find any host by that name. (#4.1.2)
    I'm not going to try again; this message has been in the queue too
     long.
    

    Can someone provide some guidance so I can overcome this problem?

    Thank you

    Regards
     
    Last edited: Sep 5, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

    This is the problem:

    Code:
    mh1:~# dig mx giganetwireless.com
    
    ; <<>> DiG 9.2.1 <<>> mx giganetwireless.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60607
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;giganetwireless.com.           IN      MX
    
    ;; ANSWER SECTION:
    giganetwireless.com.    28800   IN      MX      10 giganetwireless.com.
    giganetwireless.com.    28800   IN      MX      5 [B][COLOR="Red"]mail.giganetwireless.com[/COLOR][/B].
    
    ;; ADDITIONAL SECTION:
    giganetwireless.com.    28800   IN      A       72.169.152.211
    
    ;; Query time: 210 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Thu Sep  6 22:54:30 2007
    ;; MSG SIZE  rcvd: 90
    
    mh1:~#
    mail.giganetwireless.com, however, is a CNAME record:

    Code:
    mh1:~# dig mail.giganetwireless.com
    
    ; <<>> DiG 9.2.1 <<>> mail.giganetwireless.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34770
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail.giganetwireless.com.      IN      A
    
    ;; ANSWER SECTION:
    mail.giganetwireless.com. 28800 IN      CNAME   giganetwireless.com.
    giganetwireless.com.    28800   IN      A       72.169.152.211
    
    ;; Query time: 157 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Thu Sep  6 22:54:44 2007
    ;; MSG SIZE  rcvd: 72
    
    mh1:~#
    But it must be an A record:
    http://www.howtoforge.com/traditional_dns_howto_p5
    "In addition to that, you must not use CNAME records for MX and SOA records."
     
  3. giganet

    giganet New Member

    Thank you once again Falko


    OK, here are the curent contents of my zone file 'pri.giganetwireless.com'

    Code:
    $TTL        86400
    @       IN      SOA     ns1.dnsexit.com. web_admin.giganetwireless.com. (
                            2007090529       ; serial, todays date + todays serial #
                            28800              ; refresh, seconds
                            7200              ; retry, seconds
                            604800              ; expire, seconds
                            86400 )            ; minimum, seconds
    ;
                    NS      ns1.dnsexit.com.              ; Inet Address of name server 1
                    NS      ns2.dnsexit.com.              ; Inet Address of name server 2
    ;
    
    mail  MX      10 giganetwireless.com.
    
    giganetwireless.com.      A        72.169.152.211
    www       A       72.169.152.211
    ns2       A       64.182.102.188
    ns1       A       63.223.76.173
    webmail       A       72.169.152.211
    login       A       72.169.152.210
    mail       A       72.169.152.211
    
    ftp       CNAME  giganetwireless.com.
    
    mail.giganetwireless.com.       TXT  "v=spf1 a mx ptr ?all"
    
    ;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;
    
    
    
    
    giganetwireless.com  MX      10 mail.giganetwireless.com.
    mail       A       72.169.152.211
    www       A       72.169.152.211
    

    And here is the current ouput when I run 'dig'

    Code:
    mailman@giganetwireless:/etc/bind$ sudo dig @72.169.152.211 any giganetwireless.com
    
    ; <<>> DiG 9.3.2 <<>> @72.169.152.211 any giganetwireless.com
    ; (1 server found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50856
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;giganetwireless.com.           IN      ANY
    
    ;; ANSWER SECTION:
    giganetwireless.com.    86400   IN      MX      10 mail.giganetwireless.com.
    giganetwireless.com.    86400   IN      A       72.169.152.211
    giganetwireless.com.    86400   IN      SOA     ns1.dnsexit.com. web_admin.giganetwireless.com. 2007090529 28800 7200 604800 86400
    giganetwireless.com.    86400   IN      NS      ns2.dnsexit.com.
    giganetwireless.com.    86400   IN      NS      ns1.dnsexit.com.
    
    ;; ADDITIONAL SECTION:
    mail.giganetwireless.com. 86400 IN      A       72.169.152.211
    
    ;; Query time: 7 msec
    ;; SERVER: 72.169.152.211#53(72.169.152.211)
    ;; WHEN: Fri Sep  7 11:41:06 2007
    ;; MSG SIZE  rcvd: 180
    
    AS of this morning my domain is resolving, I setup a DNSExit account for managed DNS for 'www.giganetwireless.com'.
    Thunderbinrd barfed a bunch of email at me from a variety of senders even some 'catchall' for a couple of my WISP clients.

    Out of curiosity I went to my Yahoo account and sent a test email to president <at> giganetwireless <dot> com- next I used Thunderbird to check that accounts status and recieved the piece of email.

    At this point if I attept to send an email I am perpetually hounded for the password for president <at> giganetwireless <dot> com and even though I enter the correct password it keeps coming back at me prompting for the password and will never send the email???


    Thanks you for your help Falko

    Regards
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Please make sure you use the correct username and password in your email client.
     
  5. giganet

    giganet New Member

    Thank you Falko...


    Yesss!

    I totally screwed up in neglecting to check the 'usr' name in Thunderbird SMTP Authentication section.
    It was '[email protected]' to acommodate my old server.

    Once I set the usr to 'web1_pres' email went out, where it went I am unsure.
    Can't seem to get a reverse DNS lookup to come up PASS for some reason.

    Went and setup a Managed DNS Service account for 'giganetwireless <dot> com' at DNSExit, defined a MX and A record for the email amongst other records, when I run the NSLookup at DNSExit I see the following results:

    Code:
    NSLookup Reported by Name Server: NS1.DNSEXIT.COM
    Mail Exchanger(MX) 	Preference#
    mail.giganetwireless.com 	10
    Hosts (A Record) 	IP Addresses
    giganetwireless.com 	72.169.152.211
    login.giganetwireless.com 	72.169.152.210
    mail.giganetwireless.com 	72.169.152.211
    Alias(CName) 	Alias to Host 	IP Addresses
    www.giganetwireless.com 	giganetwireless.com 	72.169.152.211
    ftp.giganetwireless.com 	giganetwireless.com 	72.169.152.211
    
    NSLookup Reported by Name Server: NS2.DNSEXIT.COM
    Mail Exchanger(MX) 	Preference#
    mail.giganetwireless.com 	10
    Hosts (A Record) 	IP Addresses
    giganetwireless.com 	72.169.152.211
    login.giganetwireless.com 	72.169.152.210
    mail.giganetwireless.com 	72.169.152.211
    Alias(CName) 	Alias to Host 	IP Addresses
    www.giganetwireless.com 	giganetwireless.com 	72.169.152.211
    ftp.giganetwireless.com 	giganetwireless.com 	72.169.152.211
    I am able to send and receive email internal to the server presently which indicates that the email system is working- now to get the revers DNS lookup right so the outside world will accept my servers email....:D

    Thank you Falko

    Regards
     

Share This Page