Could'nt create new database, manually run and get repeating backslashes.

Discussion in 'General' started by MrCompTech, Oct 17, 2012.

  1. MrCompTech

    MrCompTech New Member

    I logged into the ISPConfig3 web console and went through the steps to create a new database. After a few minutes I tried to use PHPMyAdmin to run a script to create new tables in the database, but the database wasn't there. It had not been created. I waited a few more minutes, but still the DB had not been created.

    I logged in to the server via SSH and tried to run the script manually. But the screen started scrolling very, very fast, filling up with backslashes. Just keeps printing backslashes to the screen until I press Ctrl-C.

    Last time I had this problem I ran the ISPConfig3 update script, a stable update was available. Ran the update and then I could run the script from within the SSH console with no problems.

    This time there is no update available.

    I rebooted the server and still have the endless backslashes when trying to run the script from the SSH console.

    The ISPConfig3 console shows the database but it's not actually there, PHPMyAdmin does not show the new database I was trying to create.

    Fedora Core 13
    PHP v5.3.6
    Apache v2.2.17 (Fedora)
    ISPConfig3 v3.0.4.6
    MySQL v5.1.56

    I have plenty of HD space as show by "df -h":

    Any ideas anyone?
  2. MrCompTech

    MrCompTech New Member

    Got the idea to run the script but pipe it 'more' and now can see that it says

    17.10.2012-00:33 - WARNING - DB::query(INSERT INTO sys_log (server_id,datalog_id,loglevel,tstamp,message) VALUES ('1',0,'0','1350434020','There is already a lockfile set. Waiting another 10 seconds...')) -> mysql_query Table './dbispconfig/sys_log' is marked as crashed and should be repaired

    Used locate command to find table "sys_log":
    [[email protected] dbispconfig]# locate sys_log

    CD to /var/lib/mysql/dbispconfig/

    ran command "myisamchk -r sys_log.MYI" to fix table.

    No more repeating backslashes! YEAH!

    But still no database creates.
    But now when try to run script get:
    - DEBUG - There is already an instance of server.php running. Exiting.

    Guessing there must be a lock file that is still set. Found lock file in '/usr/local/ispconfig/server/temp/' and deleted it.

    But every time I try to run the or if I wait a couple of minutes for it to run on it's own the lock file doesnt' get deleted and the backslashes are back.

    Had to run the command "myisamchk -r sys_log.MYI" twice to fix the dbispconfig:sys_log.MYI table.

    Now the database was created and no more back slashes.

    Hope this helps somebody.

Share This Page