Corrupted /etc/shadow

Discussion in 'General' started by Numerizen, May 12, 2012.

  1. Numerizen

    Numerizen Member


    I'm not sure if it's a ISPConfig related issue, but you'll tell me.

    My server is a Debian 6 installation more or less conform to Falko's perfect server tutorial. ISPConfig is 2.2.35.

    My /etc/shadow and /etc/passwd files got corrupted, root account included.

    I fortunately managed to recover things (short night), but would like to have a hint of what happened.

    Just before everything got down, I was configuring things on a domain name I registered but never used before :

    It is the first domain I configure which is not "standard" (not .fr, .com, .net or .org).

    I noticed that my shadow file was truncated just before the users related to that domain.

    May ISPConfig have messed up the file because of the unusual domain name ?

    Thanks for reading and waiting for the wisdom of the power users around here.
    Last edited: May 12, 2012
  2. falko

    falko Super Moderator ISPConfig Developer

    I don't think so, but I suggest you update to 2.2.41.
  3. Numerizen

    Numerizen Member

    OK , I'll do that, if you confirm it won't mess up things more, given everything is not completely repaired (some missing users, etc.).

    Also, if you had any hint about the origin of the problem, besides the domain name, just to make myself feel a bit less confused, I'd be very thankful.

    PS : 2.2.41 really ? I don't see this version. Am I missing something ?
  4. Numerizen

    Numerizen Member

    Tried the upgrade to 2.2.40 and got :

    Debian 5.0.9
    ERROR: Ihr Betriebssystem wird nicht unterst?tzt! / Your operating system is not supported! / Votre systeme d'exploitation n'est pas support?!

    Besides, I can't create databases anymore : entries are created in the UI, but the relevant database does not exist.

    I tried to create it manually via PhpMyAdmin with root account, but it has not the rights to create databases, which I guess is the same problem, but I can't seem to find a solution to solve it.

    Also, /var/log/mysql.log and mysql.err are empty, so I'm suspecting something is badly wrong.
    Last edited: May 15, 2012
  5. Numerizen

    Numerizen Member

    Still stuck on this. Verified root privileges on mysql, tried different ways but no luck. I can't create any database. I can't really activate mysql logging as it is a production server.

    I was asking myself if it would be a good idea to reinstall the same ISPConfig version (2.2.35).

    Do you think it would put everything back into place again ?
  6. Numerizen

    Numerizen Member

    Sorted the databse issue. It happened permissions were wrong on the datadir directory so a chown mysql:mysql did the trick.

    I think it happened already, but can't figure why the permissions changed again.
  7. Numerizen

    Numerizen Member

    Thanks to your advice, I did some tests and I could successfully create users on the subdomain. Everything went fine. No /etc/shadow trashing or the like.

    The /var/lib/mysql directory keeps reverting to root:root ownership though, and I can't figure why.

    Maybe an idea about this ?

Share This Page