Control Panel is empty after logon

Discussion in 'Installation/Configuration' started by djoey, Mar 24, 2011.

  1. djoey

    djoey New Member

    I have migrated an ispconfig 3.0.2.2 to another server. All websites are available and working properly. But when I logon to the Control Panel Nothing appears. It logs me in but i have no option to select tabs or anything.

    I see a bunch of errors in the errorlog, i have tried upgrading to the latest stable version of ispconfig. still no luck.

    Also i have changed the server_ip in the mysql database and I changed the 000-ispconfig.conf NameVirtualHost entry to the new IP

    This didn't work as well.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to migrate the ispconfig data┬┤base from the old server to the new server as well. When you migrate a system, the ispconfig database name and ispconfig version on the old and new system should be identical. Otherwise the migration might fail as thedatabase layout has changed from ispconfig 3.0.2.x to 3.0.3.x
     
  3. djoey

    djoey New Member

    I migrated everthing using identical versions of ispconfig at first.
    I did a new install of ispconfig and I migrated the /var/www and mysql databases and the /var/mail and the /etc/passwd /etc/shadow etc..

    Afterwards everything seemed fine.
    But now a little while later i cannot login to the admin interface anymore, then i decided to upgrade to a newer version of ispconfig
     
  4. djoey

    djoey New Member

    update

    I have uninstalled ispconfig using the uninstall.php and removed the ispconfig db user from the mysql table. Afterwards I installed a fresh install of ISPconfig 3.0.3.2 in a new database with a different name.

    Afterwards when i try to login to the admin interface using the default admin admin account i have the same issue. Nothing is showing after i Logon.

    I have installed the perfect server setup with CentOS release 5.5 (Final)

    Somehow ISPConfig doesn't like it when i logon:

    apache error log shows:

    HTML:
    [Mon Mar 28 19:50:07 2011] [error] [client 94.211.210.186] PHP Warning:  array_pop() [<a href='function.array-pop'>function.array-pop</a>]: The argument should be an array in /usr/local/ispconfig/interface/lib/classes/tpl.inc.php on line 1142, referer: http://84.244.183.38:8080/index.php
    [Mon Mar 28 19:50:07 2011] [error] [client 94.211.210.186] PHP Warning:  array_push() [<a href='function.array-push'>function.array-push</a>]: First argument should be an array in /usr/local/ispconfig/interface/lib/classes/tpl.inc.php on line 1259, referer: http://84.244.183.38:8080/index.php
    [Mon Mar 28 19:50:07 2011] [error] [client 94.211.210.186] PHP Warning:  array_pop() [<a href='function.array-pop'>function.array-pop</a>]: The argument should be an array in /usr/local/ispconfig/interface/lib/classes/tpl.inc.php on line 1263, referer: http://84.244.183.38:8080/index.php
    [Mon Mar 28 19:50:07 2011] [error] [client 94.211.210.186] PHP Fatal error:  vlibTemplate Error: Parse error!<br />To debug this file, use vlibTemplateDebug instead of vlibTemplate in the class instantiation(i.e. new vlibTemplateDebug). in /usr/local/ispconfig/interface/lib/classes/tpl_error.inc.php on line 83, referer: http://84.244.183.38:8080/index.php
    [Mon Mar 28 19:50:07 2011] [error] [client 94.211.210.186] PHP Warning:  array_key_exists() [<a href='function.array-key-exists'>function.array-key-exists</a>]: The second argument should be either an array or an object in /usr/local/ispconfig/interface/lib/app.inc.php on line 85, referer: http://84.244.183.38:8080/index.php
    [Mon Mar 28 19:50:07 2011] [error] [client 94.211.210.186] PHP Warning:  array_push() [<a href='function.array-push'>function.array-push</a>]: First argument should be an array in /usr/local/ispconfig/interface/lib/classes/tpl.inc.php on line 1030, referer: http://84.244.183.38:8080/index.php
    [Mon Mar 28 19:50:07 2011] [error] [client 94.211.210.186] PHP Warning:  array_pop() [<a href='function.array-pop'>function.array-pop</a>]: The argument should be an array in /usr/local/ispconfig/interface/lib/classes/tpl.inc.php on line 1142, referer: http://84.244.183.38:8080/index.php
    [Mon Mar 28 19:50:07 2011] [error] [client 94.211.210.186] PHP Warning:  array_push() [<a href='function.array-push'>function.array-push</a>]: First argument should be an array in /usr/local/ispconfig/interface/lib/classes/tpl.inc.php on line 1259, referer: http://84.244.183.38:8080/index.php
    [Mon Mar 28 19:50:07 2011] [error] [client 94.211.210.186] PHP Warning:  array_pop() [<a href='function.array-pop'>function.array-pop</a>]: The argument should be an array in /usr/local/ispconfig/interface/lib/classes/tpl.inc.php on line 1263, referer: http://84.244.183.38:8080/index.php
    [Mon Mar 28 19:50:07 2011] [error] [client 94.211.210.186] PHP Fatal error:  vlibTemplate Error: Parse error!<br />To debug this file, use vlibTemplateDebug instead of vlibTemplate in the class instantiation(i.e. new vlibTemplateDebug). in /usr/local/ispconfig/interface/lib/classes/tpl_error.inc.php on line 83, referer: http://84.244.183.38:8080/index.php
    
    
     
  5. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    getenforce
    ?
     
  6. djoey

    djoey New Member

    The output = Disabled
     

Share This Page