control panel access lost while upgrading from v35

Discussion in 'Installation/Configuration' started by gauthier, Sep 12, 2010.

  1. gauthier

    gauthier New Member


    I am newbie. I am using debian 4.0, I tried to upgrade ispconfig2 from v35 to v37. The sistem warns about some update to run:

    I open a new shell and run it but it fails with:

    I tried to apt-get update, but it fails with:

    And other similar errors.

    I went back to the first shell and answer "no" (I am not sure spamassasin is up to date) then the ispconfig instalation stops.

    I was happy I aparently managed to cancel the upgrade without breaking the ispconfig instalation but actually... I have lost control panel access!!!

    Thanks for any help.
  2. gauthier

    gauthier New Member


    gave me back my control panel. I suppose it was obvious for most of you but it was not so obvious for me.

    After some many operations, adding mirror in sources.list, upgrading perl... it seems I finally manage to install libnetaddr-ip-perl.

    Now I run newly the command:

    apt-get install libnetaddr-ip-perl libarchive-tar-perl

    And I get the following:

    Please, can anybody tell me if I can stop here, run the ispconfig upgrade to v37 and say "yes" when ISPconfig installation ask if I am absolutly sure libnetaddr-ip-perl libarchive-tar-perl are installed?

    Last edited: Sep 12, 2010
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Please see release notes, they contain special instructions for users of debian 4:

    as some packages of debian 4 are too old for current spamassassin versions.

    And dont forget to run "mkdir /root/ispconfig" before you try the update again or you will loose the database contents.
  4. gauthier

    gauthier New Member

    Thanks Till,

    Some little things was unclear for me so I decided to upgrade from debian etch to lenny, as I read in one of your post. I had some fears but I finally managed to do it. Sites, mail server, ftp, ispconfig are all running fine... on debian-lenny now.

    It's time to go to sleep so tomorrow I'll go on with the upgrade to ispconfig v37 and try to reboot :eek:

    Thankyou very much for your help.
  5. gauthier

    gauthier New Member

    My system says:

    Thank you.
  6. falko

    falko Super Moderator ISPConfig Developer

    Is it working now?
  7. gauthier

    gauthier New Member


    Thank you.

Share This Page