connection to imap server failed

Discussion in 'Server Operation' started by marksman, May 19, 2013.

  1. marksman

    marksman New Member

    hi for all and thanks for falko

    i was implementing this artical

    and all work fine except the mail server gives me on roundcube and SquirrelMail

    i already create from ispconfig users and mail boxes but cant connect to mail server and i cant login

    this is example webmail account to my mail server
    user:[email protected]
  2. marksman

    marksman New Member

    hi all

    its more than 60 views and no reply is there any problem????

    help please
  3. marksman

    marksman New Member

    OMG no support here
  4. vincej97

    vincej97 New Member

    I'm having that same problem an came across this posting to get help.. I will check back later.
  5. monkfish

    monkfish New Member

    Have a look in /var/log/maillog see if you can spot any errors.

    What port is your imap server running on? Is it running?

    "netstat -A inet -nlp" or similar might show you if your imap server is running.

    In roundcube config file, what do you have $rcmail_config['default_host'] and $rcmail_config['default_port'] set to?

    Does roundcube config match your imap config?

    I have dovecot listening on ports 143 and 993. However, my firewall rules dicate that outside users can only access IMAPS on 993. Roundcube running on the same machine is set to connect on 143.
  6. oldretiredman

    oldretiredman New Member

    I'm having this issue also, made a lot of changes so I'm going to have to go through the tutorial again and try to cross and dot everything again.

    It's when I log in correctly, if I don't log in correctly, it works as expected, ~"You have failed to login,etc."

    The issue certainly starts at the email not being sent correctly.

    (newaliases was run)

    /var/log/maillog when trying to mailx [email protected]:
    Last edited: May 28, 2013
  7. vincej97

    vincej97 New Member

    Mail Server help

    I've done all the checks for making sure the imap, smtp and all the ports are open and process are running. Still I can not configure my mail server or login to Squirrelmail. I installed my server using the The Perfect Server - Fedora 15 x86_64 [ISPConfig 3] and followed all the steps and it works great. but when i came to putting my username and password in the Squirrelmail "Webmail" page I could not get in. Is there a "step-by-step configuration tutorial on how to setup squirrelmail after installing and configuring the server from using The Perfect Server - Fedora 15 x86_64 [ISPConfig 3]? I would certainly appreciate al help in this area. :)

    Thanks in advance!
  8. monkfish

    monkfish New Member


    Watch the mail log file see if you get any errors when you attempt a login to squirrelmal. "tail -f /var/log/maillog" in your console should do it.

    You could also try a "tail -f /var/log/httpd/error.log" or "tail -f /var/www/<domain>/log/error.log and watch to see if you get any errors from apache when you login in.

    Is there any particular reason why you chose Fedora 15? According to Redhat site, official support for that ended 26JUN12. If its a Redhat derivative you're most comfortable with, perhaps look at CentOS 6.4 instead? Of course that won't automatically get your mail working but just something to consider.
  9. monkfish

    monkfish New Member


    unable to look up host Name or service not known
    is most likely to be a dns lookup error.

    Your "netstat" output does not appear to show any listening dns server, did you configure dns at all? Or are you using name resolution external to that machine?

    Do a "cat /etc/resolv.conf" and find out your nameservers. The error above is likely due to the dns servers you are using cannot resolve the name.

Share This Page