Connection timed out

Discussion in 'Installation/Configuration' started by SeaWolf, Oct 10, 2005.

  1. SeaWolf

    SeaWolf New Member

    Hi! Is anybody know why in outlook, I have setup my email account and if I click on TEST, I have the email from test and everything is fine. When I'm trying to send email to my hotmail account, I see that the email passed and is now in the sent folder but on my hotmail account I didn't receive the email. And if I try to send email from hotmail to my server, same thing happen, in hotmail I see the email in the sent folder and I have no error msg who come back after few minutes. Here is my mail:


    Oct 9 21:34:05 Cronos postfix/qmgr[6416]: 8F92C37ED1: from=<webmaster@devXperience.com>, size=2445, nrcpt=1 (queue active)
    Oct 9 21:34:05 Cronos postfix/qmgr[6416]: B1FCB2016C: from=<webmaster@devXperience.com>, size=2455, nrcpt=1 (queue active)
    Oct 9 21:34:35 Cronos postfix/smtp[6455]: connect to mx3.hotmail.com[65.54.167.5]: Connection timed out (port 25)
    Oct 9 21:34:35 Cronos postfix/smtp[6457]: connect to mx2.hotmail.com[65.54.166.230]: Connection timed out (port 25)



    Thanks for help,
    Martin
     
  2. till

    till Super Moderator

    It seems that your server is not connected to the internet. This might be a router or Firewall issue.
     
  3. SeaWolf

    SeaWolf New Member

    The firewall on Suse 9.3 is disabled and on the router theses ports are open: 21, 22, 25, 80, 81, 110 and 3306. Do I need more?

    ftp, ssh, http, ispconfig, and mysql is working from the internet.

    thanks,
    Martin
     
  4. falko

    falko Super Moderator

    Can you run
    Code:
    telnet mx2.hotmail.com 25
    ? If the command hangs, then I'm almost sure it is a firewall issue...
     
  5. SeaWolf

    SeaWolf New Member

    yes the command hangs, now where should I check to the suse firewall settings? Because I've DMZ my server on my router few minutes to try and it doesn't work, so do you thing the problem is from Suse?

    Thanks,
    Martin
     
  6. falko

    falko Super Moderator

    There are some SuSEfirewall scripts in /etc/init.d. You can use them to stop the firewall (e.g. /etc/init.d/<scriptname> stop). Then try the telnet command again.
     
  7. SeaWolf

    SeaWolf New Member

    Now it's ok to send email, but I cannot receive them :confused: . If I send an email from my hotmail accout to my server, I just have an error email (later) in my hotmail box. Suse's firewall is off and all needed ports are open on the router.

    any ideas? :(

    Martin
     
  8. falko

    falko Super Moderator

    Are you sure that the mail actually arrives on your system and not another one? Do you see anything in the mail log when you send a message from your hotmail account?
    What's the exact error message you find in your hotmail account?
     
  9. SeaWolf

    SeaWolf New Member

    Here is the first one:

    This is an automatically generated Delivery Status Notification.

    THIS IS A WARNING MESSAGE ONLY.

    YOU DO NOT NEED TO RESEND YOUR MESSAGE.

    Delivery to the following recipients has been delayed.


    and the second one:

    This is an automatically generated Delivery Status Notification.

    Unable to deliver message to the following recipients, due to being unable to
    connect successfully to the destination mail server.
     
  10. till

    till Super Moderator

    Is the server housed in a datacenter? If naot and it is a DSL line, your provider may have blocked connections on port 25 to your server to prevent clients from housing their Servers at home.
     
  11. SeaWolf

    SeaWolf New Member

    hmm.. yeah maybe.. I'll check and let you know, thanks a lot.

    Martin
     
  12. SeaWolf

    SeaWolf New Member

    Here is the blocked ports:

    IN : 25,80,135,137,138,139,161,162,445,1080,4444
    OUT : 25,135,139,445,4444

    When hotmail send email to my server, which port is used on my server?
     
  13. falko

    falko Super Moderator

    It's port 25.
     
  14. SeaWolf

    SeaWolf New Member

    so it won't work... ok then and thanx a lot for ur time.
     

Share This Page