Connection Refused on PHP5-FPM Setting

Discussion in 'ISPConfig 3 Priority Support' started by Steveorevo, Nov 6, 2014.

  1. Steveorevo

    Steveorevo Member HowtoForge Supporter

    I've set up ISPConfig following the manual without issue at least a half dozen times. However, this time on Ubuntu 14.04 + Apache I get a 500 Server Error on my initial site that is set to PHP5-FPM (FastCGI works). This hasn't been a problem on prior setups and I'm not sure where else to look. PHP5-FPM services appear to be running but the 500 persists and I don't see PHP5-FPM when listing processes (top) on the CLI like my other active PHP5-FPM servers. This new ISPConfig Server's first site error log appears below.

    [Wed Nov 05 23:22:08.705535 2014] [fastcgi:error] [pid 26064] (111)Connection refused: [client XXX.XXX.XXX.XX:35885] FastCGI: failed to connect to server "/var/www/clients/client1/web1/cgi-bin/php5-fcgi-*-80-somedomain.org": connect() failed

    [Wed Nov 05 23:22:08.705663 2014] [fastcgi:error] [pid 26064] [client XXX.XXX.XXX.XXX:35885] FastCGI: incomplete headers (0 bytes) received from server "/var/www/clients/client1/web1/cgi-bin/php5-fcgi-*-80-somedomain.org"

    Any ideas where else to look/check?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please do this:

    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php

    If you had already a 3.0.5.4 release installed, then choose no when the updater asks to reconfigure services, otherwise choose yes.

    Then login to ispconfig, disable this website, press save, then enable it again and press save and wait at least 1 minute until you test the site again.
     
  3. Steveorevo

    Steveorevo Member HowtoForge Supporter

    Done! ISPConfig did update from 3.0.5.4p4, now indicating p5. The error 500 still appears, but the error.log has changed (SoftException). It now states:

    [Thu Nov 06 01:25:40.590174 2014] [:error] [pid 3010] [client XXX.XXX.XXX.XXX:33067] SoftException in Application.cpp:350: UID of script "/var/www/clients/client1/web2/web/test.php" is smaller than min_uid
    [Thu Nov 06 01:25:40.590284 2014] [core:error] [pid 3010] [client XXX.XXX.XXX.XXX:33067] End of script output before headers: test.php

    For reference, test.php simply contains <?php phpinfo(); ?>, still working under Fast-CGI. Trying to think of anything unorthodox from prior installs; I did install a wildcard cert for ISPConfig itself (which still works w/out issue as far as I can tell).

    Any other thoughts on items to examine would be greatly appreciated.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    your test.php file is woned by the wrong user. chown it to the web user and client group of the website.
     
  5. Steveorevo

    Steveorevo Member HowtoForge Supporter

    Done! It appears to be working now. Although phpinfo is returning:

    Server API: CGI/FastCGI
    Configuration File (php.ini) Path: /etc/php5/cgi
    Loaded Configuration File: /etc/php5/cgi/php.ini
    Scan this dir for additional .ini files: /etc/php5/cgi/conf.d

    Is this correct under apache (I cleared cache and copied to another filename with correct chown as well). I noted that under one of my prior systems ISPConfig + NginX phpinfo properly reports:

    Server API: FPM/FastCGI
    Configuration File (php.ini) Path /etc/php5/fpm
    Loaded Configuration File: /etc/php5/fpm/php.ini
    Scan this dir for additional .ini files: /etc/php5/fpm/conf.d

    Should it not report "fpm" in any of the file paths or say "FPM/FastCGI"; am I missing something still?
     
    Last edited: Nov 6, 2014
  6. Steveorevo

    Steveorevo Member HowtoForge Supporter

    Had to re-apply. All is well. Thank you for your help Till!!!

    a2enmod actions fastcgi alias
     

Share This Page