Connection drop during upgrade

Discussion in 'Installation/Configuration' started by peter.zagar, Dec 17, 2008.

  1. peter.zagar

    peter.zagar New Member

    Hi, I would really appreciate any help on this.

    Short story:

    Had the ISPConfig server up an running on the remote location.
    Centos 5.2 Perfect Install + ISPConfig 2.2.28
    All users, domains everything ready.

    Tried to upgrade to 2.2.29 over ssh.
    During the compiling, the connection dropped.
    I was unable to get back to that session.

    Since I did not know of the internal workings of ISPConfig I followed the suggestion to delete the install_ispconfig folder and start the installation again.

    This time the installer did not recognize the system as ISPConfig system and tried to start a fresh install.

    As I searched the forum, I learned that the installer replaces /root/ispconfig folder. I have no backup of that folder. This folder is now missing.
    The mail is working, the ISPConfig admin interface is not.

    I have backups of:
    /etc
    /www

    Should I try to undelete install_ispconfig folder that I removed?
    Could I try to make a backup of mysql ispconfig_db database and reinstall (new install)?
    Would that preserve users created?

    Thanks for all the help!

    Only now I have learned that I should use screen for the upgrade..
    http://www.howtoforge.com/forums/showthread.php?t=28561

    Regards, Peter
     
  2. radim_h

    radim_h Member

    First:
    make backup of your ispconfig database
    and /home/admispconfig + /root/ispconfig direcotries..
    if anything goes wrong you can put the directories and database back and everything runs as before

    against drop - use "screen" command which allows you connect back to your session when connection si dropped
     
    Last edited: Dec 18, 2008
  3. till

    till Super Moderator

    Just run the command:

    mkdir /root/ispconfig

    and then unpack the ispconfig tar.gz and run the setup script again. ISPConfig restores the content of the /root/ispconfig filer automatically during update.
     
  4. peter.zagar

    peter.zagar New Member

    Ok, the following folders are in place and intact and I also have backups:

    /etc
    /home/admispconfig
    /home/ispconfigend
    /var/lib/mysql
    /var/www
    + mysqldump of db_ispconfig

    The only folder missing from the failed upgrade is:

    /root/ispconfig

    This obviously caused the installer script to think that there is no previous ISPConfig installation on the system. So when I tried to upgrade, the installer wanted to do fresh install.

    So, Till, if I make an empty directory /root/ispconfig and then rerun the installation, the installer will find existing ISPConfig installation with all the users, domains, etc.?

    Thanks,

    Peter
     
    Last edited: Dec 18, 2008
  5. falko

    falko Super Moderator

    Yes, that's right.
     
  6. falko

    falko Super Moderator

    BTW, to prevent this from happening again, you can use screen: http://www.howtoforge.com/linux_screen :)
     
  7. peter.zagar

    peter.zagar New Member

    Thanks, I did what you advised (using screen) and the installer indeed found an existing ISPConfig installation.

    I have however, at least one more problem.
    ISPConfig panel does not start.

    The browser says:
    Code:
    SSL received a record that exceeded the maximum permissible length.
    (Error code: ssl_error_rx_record_too_long)
    
    The console output:
    Code:
    /etc/init.d/ispconfig_server start
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    ISPConfig system is now up and running!
    
    Error log:
    Code:
    cat /root/ispconfig/httpd/logs/error_log
    [Mon Dec 22 10:37:04 2008] [error] mod_ssl: Init: Unable to read server certificate from file /root/ispconfig/httpd/conf/ssl.crt/server.crt (OpenSSL library error follows)
    [Mon Dec 22 10:37:04 2008] [error] OpenSSL: error:0D06B08E:asn1 encoding routines:ASN1_D2I_READ_BIO:not enough data
    
    Should I try to recreate certificates like this?
    http://www.howtoforge.com/forums/showthread.php?t=121
    If yes, I noticed that there is a password to be entered:
    Do I have to set a new password here?
    I do not remember having to enter any passwords for serverkey when doing fresh installation. Why now?
    Is this the same option as in the ISPConfig Installation Manual, step 7 and 8?
    I want to be able to restart the machine remotely.
     
    Last edited: Dec 22, 2008
  8. falko

    falko Super Moderator

    Yes.

    You can make up a password here.

    You will be able to reboot the machine remotely. :)
     
  9. peter.zagar

    peter.zagar New Member

    Hello again!
    Big thanks to everyone, especially falko, for helping me with this.

    Your advice helped perfectly.
    Since it was not so urgent, I waited a while, and only resolved this issue last week.
    It just worked.

    With best regards,

    Peter

    Keep it up!!!
     

Share This Page