Connecting USB drive in VMware

Discussion in 'HOWTO-Related Questions' started by warnerwhite, Mar 17, 2009.

  1. warnerwhite

    warnerwhite New Member HowtoForge Supporter

    I am running VMware Server 2 on Ubuntu intrepid ibex. I have created an XP Professional virtual machine, but am unable to connect my USB drive. I have installed VMware tools, and have installed the USB controller, and it appears in the hardware panel of the Summary tab, which says, "Autoconnect enabled." On the status bar of the vm the drive appears when I insert a flash drive, and so do the various usb devices (printer, external hard drive, etc.), all marked witha big red X. When I right click and say Connect, the red X disappears temporarily, but then it reappears and up pops a message that says, "Remote USB device error: Remote device disconnected: an error occured while sending data." I also am unable to connect to the internet, but the connection to my local network is operational. I tried disabling Network adapter 1, but all that did was to disconnect me from my local network.

    Any ideas about what to do?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    I can't say anything about the USB problem, but regarding the networking problem: do you use bridging to your VMware guest? Do you have a DHCP server in your network (usually there's a DHCP server on the router)?
     
  3. christr

    christr New Member

    Warner:

    Is the USB device your trying to connect recognized in Linux? Can you mount it & use it on the host OS? That's a requirement before you can try to use it in a VM. If Ubuntu doesn't play nice with it the VM clients won't either. :(

    --Chris
     
  4. warnerwhite

    warnerwhite New Member HowtoForge Supporter

    Yes, it does get mounted in linux. When I plug a memory stick into it up pops linux's Nautilus showing its contents. But how to get the vm to see it?
     
  5. saggy12491

    saggy12491 New Member

    i had that problem too...but resolved it

    try this,
    select your virtual machine on the side panel (on the web-browser) then you'll see a usb sign appear to the right of the reset button on top, click on it then select the usb device you want to activate and that's it.
    it will take some time on your virtual machine (about a minute) to install the device and you should be able to use it.
    it worked for me.
     

Share This Page