Connecting to Mysql database from Dreamweaver

Discussion in 'Installation/Configuration' started by The General, May 30, 2006.

  1. The General

    The General New Member

    i have managed to set up a site in dreamweaver that is located on the ispconfig server and i can post files to and from the ispconfig folders. i have set up a database with remote access enabled for the domain, but i cant find any help on connecting to the database my dreamwever ip address is 192.168.0.1 my ISPconfig is on a DMZ on 192.168.1.2


    Dreamwever Connection setting are

    Connection name :Test
    MySQL Server:192.168.1.2
    Username:web3_u1
    database:web3_db1

    the netstat -tap is:

    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 2216/xinetd
    tcp 0 0 *:32769 *:* LISTEN 1855/rpc.statd
    tcp 0 0 *:pop3s *:* LISTEN 2216/xinetd
    tcp 0 0 *:mysql *:* LISTEN 2307/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 2216/xinetd
    tcp 0 0 *:imap *:* LISTEN 2216/xinetd
    tcp 0 0 *:sunrpc *:* LISTEN 1837/portmap
    tcp 0 0 *:81 *:* LISTEN 2663/ispconfig_http
    tcp 0 0 *:ftp *:* LISTEN 2966/proftpd: (acce
    tcp 0 0 192.168.1.3:domain *:* LISTEN 2949/named
    tcp 0 0 192.168.1.2:domain *:* LISTEN 2949/named
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 2949/named
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2172/cupsd
    tcp 0 0 localhost.localdomain:5335 *:* LISTEN 2154/mDNSResponder
    tcp 0 0 *:smtp *:* LISTEN 6566/master
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2949/named
    tcp 0 0 localhost.localdomain:50284 localhost.localdomain:http TIME_WAIT -
    tcp 0 0 localhost.localdomain:60087 localhost.localdomain:ftp TIME_WAIT -
    tcp 0 0 *:http *:* LISTEN 2852/httpd
    tcp 0 0 *:ssh *:* LISTEN 2207/sshd
    tcp 0 0 *:https *:* LISTEN 2852/httpd


    Any ideas cus my brain is exploding!... :)
     
    Last edited: May 30, 2006
  2. falko

    falko Super Moderator

    Which hostname do you use to connect to MySQL? Is it one of the hostnames listed in the Host column in the mysql.users table?
     
  3. The General

    The General New Member

    sorry for the late reply,

    well ive have tried ns1.***.com which is in the mysql.users file but i keep getting "ERROR 404" from dreamweaver i have tried the local IP address, net public ip address in fact i have even thought about trying my mothers maiden name!LOL.

    if i put a PHP page up on the server and call it via internet explorer and code the login to mysql server as $host=localhost $user=root $password=*** it all works fine. i just cant get the connection between dreamweaver and Ispconfig's Mysql to work ... hO hum!
     
  4. till

    till Super Moderator

    Are you sure you get this error "ERROR 404" from mysql? This is an http error code.

    The mysql is not from ISPConfig, it is the database package from your linux distribution. Did you check the "external access" checkbox as you created the database?
     
  5. The General

    The General New Member

    i don't get error "404" from MySQL i get it from Dreamweaver when i try to make a connection to the MySQL database on the server. I also know that Mysql seperate a seperate package to ISPConfig. I just cant understand why i cant make a connection to MySQL from Dreamweaver MX. I can log onto the server from Dreamweaver MX and get a display of the folders for the Site that i am working on but when i go to maje a datbase connection i just get the above error.

    Thx
     
  6. falko

    falko Super Moderator

    Does ns1.***.com exist in DNS? Please check with
    Code:
    dig ns1.***.com
     
  7. The General

    The General New Member

    The "A record" points to my public IP address so i guess so! The only thing i was thinking was could it be because im on a differant network address as in Dreamweaver on GREEN 192.168.0.1 and Mysql on DMZ on 192.168.1.2
     
    Last edited: Jun 1, 2006
  8. falko

    falko Super Moderator

    Does your router forward port 3306 to your MySQL server?
     
  9. The General

    The General New Member

    Yep port is forwarded to server and firewall port on server is open
     
  10. edge

    edge HowtoForge Supporter

    Try using the IP:3306 instead of the domainname.

    ** edit..
    I see.. You've been doing it that way allready :-/

     
  11. falko

    falko Super Moderator

    Maybe your router doesn't support loopbacks into your local network?
     
  12. Anim

    Anim New Member

    I have just successfully done this today using dreamweaver 8

    When creating a database link in dreamweaver make sure that the testing server has a host directory of /web or you will get errors as dreamweaver tries to create (and gets denied) files in the wrong folder.

    My Server connection (from within the dreamweaver panel) are as follows:

    SQLServer: Localhost
    Username: web1_u1
    Password: *******
    Database: web1_db1

    You can find out your MySQL details in ISPConfig under ISPManager, <Select your site>, Options TAB and your databases and users will be listed there. If not click the new button and create one.

    Edit: The testing server should be setup to FTP into your webserver using normal FTP login details.

    Hope that helps, if not just ask
    Anim
     
    Last edited: Jun 6, 2006
  13. azteca2137

    azteca2137 New Member

    Accessing MySQL with Dreamweaver

    I manged to connect via FTP but while trying to access the database a get the following error:

    1) There is no test server in execution at this server
    2) The specified test server for this site is not assigned to the URL http://localhost/_mmServerScripts/MMHTTPDB.php

    How can I correct this error?

    The server connection is as follows:

    MySQLServer: Loclahost
    username: web1_u1
    password: *******
    database: web1_db1

    Any Idea?
     
  14. till

    till Super Moderator

    Please use the servers IP address or hostname instead of localhost as mysql server. Additionally make sure, that you enabled externel access in the mysql database settings in ispconfig for this database.
     
  15. azteca2137

    azteca2137 New Member

    Till, thank you for your response, I tryied that already and get the same message, can you think about something else that can be done?

    Thanks in advance
     
  16. falko

    falko Super Moderator

    Do you get an error message when you try to login with the user credentials on the shell, e.g. like this:

    Code:
    mysql -h [I][hostname you specified in Dreamweaver][/I] -u [I][username you specified in Dreamweaver][/I] -p
     
  17. azteca2137

    azteca2137 New Member

    Falko, thanks for the help, via shell the connection can be made and I can access the databases, it could be a Dreamweaver configuration?
     
  18. till

    till Super Moderator

    Either a setting in dreamweaver or a firewall problem. Please check if you have any firewalls between your workstation that runs dreamweaver and the server or if you run a firewall on the server.
     
  19. make-fun

    make-fun Member

    Hi there,

    here's what has made life much easier for me, when using DW, PHP/MySQL in a local testing environment.
    1. Edit your Windows Host-File (C:\WINDOWS\system32\drivers\etc\hosts) with some Domain-Names which will be routed to your own Computer/Localhost/Testserver
      Let's say you're working on a project called "newhowtoforge" then set an entry in a new line:
      Code:
      127.0.0.1    www.newhowtoforge--2--mynetwork.com
      (you will never be able to access this domain if someone would really register it, as you are telling your computer to look for it at IP 127.0.0.1 - your machine)

    2. Install XAMPP for Windows on your local machine (http://www.apachefriends.org)

    3. Edit the XAMPP Apache-httpd.conf in D:\apachefriends\xampp\apache\conf\httpd.conf (if you install in D:)
      Look for the section "NameVirtualHost 127.0.0.1" in httpd.conf and add a VirtualHost for your project called "newhowtoforge":
      Code:
            <VirtualHost 127.0.0.1>
             ServerName www.newhowtoforge--2--mynetwork.com
             ServerAlias www.newhowtoforge--2--mynetwork.com
      
             DocumentRoot "D:/yourProjects/newhowtoforge"
             ErrorLog "D:/yourProjects/newhowtoforge/error.log"
             TransferLog "D:/yourProjects/newhowtoforge/access.log"
            </VirtualHost>
    4. Set up your DW-Site:
      * Local Info:
      Site-Name: newhowtoforge
      Local-Dir: D:/yourProjects/newhowtoforge/

      * Remote-Info: all info needed to publish your project in the internet
      (in your case this could be the LinuxMachine running the ISPConfig, somewhere in your network)

      * Testserver
      Servermodel: PHP MySQL
      Access/Connection: Lokal/Network
      Testserver-Dir: D:/yourProjects/newhowtoforge/ (maybe need to use backslashes"\" — D:\yourProjects\newhowtoforge\)

      URL-Prefix: http://www.newhowtoforge--2--mynetwork.com

    5. In DW you can easly set up a Connection to MySQL using the MySQL-Server installed with XAMPP, available on localhost.

    6. And when you hit F12 from now on, you'll get a nice looking http://www.newhowtoforge--2--mynetwork.com in you browser and have a rock solid testing environment

    It saves me all the hassle for many years already ;-)
     
    Last edited: Feb 26, 2008
  20. azteca2137

    azteca2137 New Member

    It's up and running now

    Thanks for all the advices, at the end we change the Dreamweaver version to CS3 and all worked fine, it seems that is a problem with compatibility in Dreamweaver MX with MySQL 5.0.27 (something with the password encryption I think).
     

Share This Page