Connecting Smart Phones To Email

Discussion in 'Server Operation' started by White, Dec 6, 2011.

  1. White

    White Member

    Ok, now i have my popstfix sorted to i can send and receive all emails from anywhere in the world i find i cannot connect my smart phone.

    I have my msoutlook setup to go fetch my emails no problem but if i try and set up an account using the same settings in my smart phone it just fails.

    I have tried all manner of combinations of none/ssl/tls/combined nothing works, anyone any ideas it would be nice toi check on my server emails while out and about.
     
  2. nbhadauria

    nbhadauria New Member

    Tell us more about your account ..

    server ??
    port (ssl or not) ?

    user auth ?

    which phone ?
     
  3. White

    White Member

  4. nbhadauria

    nbhadauria New Member

    port (ssl or not) ?
     
  5. White

    White Member

  6. nbhadauria

    nbhadauria New Member

    Check for following error in /var/log/mail.log

    when you try to add account:

    warning: unknown[1.2.3.4]: SASL PLAIN authentication failed: no mechanism available
    *
     
  7. SwOsHiE

    SwOsHiE New Member

    Be sure to check if your phone company is blocking port 25 as this is a common thing, mostly to fight spam.

    I have this problem both at home and my phone, solved this by redirecting port 587 to 25 at the main router infront of the mailserver.
     
  8. White

    White Member

    mail.log shows msoutlook connections and last google connection but shows nothing for the several attempts i have made from my phone.
     
  9. SwOsHiE

    SwOsHiE New Member

    Also, I would recommend using IMAP if you can use this mode with your server. POP3 will store your emails at the local computer and will not sync it from the server to every device as IMAP does.

    Maybe you know this already, but just a recommendation as I said :p
     
  10. White

    White Member

    would imap already be setup on my server? (having followed the howto mentioned above)
     
  11. nbhadauria

    nbhadauria New Member

    yes, and if you like check try this on your server ..

    $ telnet localhost 143

    when it says connected run the command with your user name and password..

    a login username password
     
  12. White

    White Member

    i got this

    Code:
    server1:~# telnet localhost 143
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2008 Double Precision, Inc.  See COPYING for distribution information.
    
    a login [email protected] **********
    a OK LOGIN Ok.
    
    
    is this good?
     
    Last edited: Dec 8, 2011
  13. nbhadauria

    nbhadauria New Member

    ya it's good our imap is working and your Login Credentials are also working file..
     
  14. White

    White Member

    i tried to connect my smart phone no joy, i also added port 143 to my router i have tried setting host to mail.myhost.com and imap.myhost.com

    do you have a list of settings i should be looking at please?
     
  15. White

    White Member

    Does anyone one know the correct settings for connecting a smart phone to their server ?
     

Share This Page