...connect to transport amavis: Connection refused

Discussion in 'Installation/Configuration' started by ubuntupat, Aug 18, 2009.

  1. ubuntupat

    ubuntupat New Member

    Hi,

    I have installed ispconfig 3.0.1.1 on a Ubuntu 9.04 server.

    I followed the installation procedure found here.

    The problem:

    I was not able to have mails sent out from my mail server when sent from another machine.

    Receiving emails was not an issue.
    Last week I started to play around with the configs. Either through the
    Ispconfig web interface or directly on postfix using webmin.

    The issue today, what I need to have resolved:

    Currently I have 700+ emails stuck in cue that can't be delivered.

    The log file in ispconfig says:

    - in Mail warn-Log:
    Aug 18 18:05:57 ubuntu2 postfix/qmgr[18688]: warning: connect to transport amavis: Connection refused

    - in Mail-Log:
    Aug 18 19:54:27 ubuntu2 postfix/error[23637]: BD2B0166291: to=, relay=none, delay=278219, delays=278213/5.7/0/0.12, dsn=4.3.0, status=deferred (mail transport unavailable)

    I attach my main.cf and master.cf + postconf -n and netstat -l for reference if needed.

    Thank you in advance for your help and suppoort.

    Brgds

    Patrick
     

    Attached Files:

  2. till

    till Super Moderator

    Using webmin on a ispconfig server often breaks the setup. Do you made a backup of the postfix config files before you edited them?
     
  3. ubuntupat

    ubuntupat New Member

    Hi Till,
    Thank you for your reply.

    No, I have not made a backup of the files, but renamed the modified ones and retrieved the original ones that are automatically backed by the system.

    I have to say, that I played around late last night and got it working now.

    I now will have to compare all log files and config files to see what was wrong.

    Thank you for your help.

    Brgds

    Patrick
     

Share This Page