confius on configuring behind firewall...

Discussion in 'Installation/Configuration' started by crypt3rc0d3, Feb 15, 2006.

  1. crypt3rc0d3

    crypt3rc0d3 New Member

    greeting to all.. :)

    before i write up my problem..i'm want to say sorry if my grammar very bad..

    I'm still confius about how to running ISPconfig behind firewall..can anyone explain more about this..? Acctually i'm now build up ISPconfig running on fc4which ISPconfig will handle 6 domain for my customer.. on installation it's ok and no problem happen.. but the problem happen when trying to recieving email from postfix mta..it's always keep relaying denied and say my domain not available..sorry i cant post the error because i'm already fresh install my fc4 because some mistake happen.. the question on my confius is :

    1). is it each domain must point to 1 ip only or can it separate each domain handle 1 private ip?

    2). on postfix configuration what sould i set to make sure it can handle all this 6 domain without showing any error message like relaying denied, bounce, and domain not available...?

    3). can anyone give me example instruction to configure ISpconfig properly behind firewall...

    4). is it possible if i install ISPconfig at Redhat enterprise linux 4 which edit on /etc/redhat-release to match fedora core 4 configuration settings?

    thank you if any one can help me out with this problem... i hope falko or erveryone can give instruction in details...

    regards

    ridzuan ;)
     
  2. falko

    falko Super Moderator

    Your web sites can share one IP address. But if you have SSL web sites, then you need one IP address per SSL web site!

    When you send emails using an email client like Outlook or Thunderbird, make sure you enable "Server requires authentication." in your email client. Then you won't see the "Relaying denied" error anymore.
    Also, make sure the MX records point to your router's public IP address, and you must forward port 25 from your router to your ISPConfig system.

    When you install ISPConfig, you must specify the system's local IP address, not your router's public one. Then you must forward all needed ports (e.g. 21, 22, 25, 53, 80, 81, 110, 143, 443, ...) from your router to your ISPConfig system.

    That should work, though I haven't tested it.
     

Share This Page