Configuring Nameservers

Discussion in 'Installation/Configuration' started by mikenuun, Sep 13, 2007.

  1. mikenuun

    mikenuun New Member

    I just installed the latest ISPconfig on my Ubuntu Server machine.
    Everything seems to work nice,
    But now to the point.

    I'm trying to point the nameservers of my already running domain to my ispconfig server.

    When i just ad a site in the isp configure it says many things like, missing NS records and things.

    Does someone know what to do for me ?
    I really dont know here to start.

    Thanx in advance,

    the following error message appears at the SIDN NL domain registery :
    ** Full check report:
    * general reports
      Error: at least two visible distinct name servers are needed.
        If all your name servers are unreachable on the Internet, your domain
        is liable disappear. This may cause serious problems, such as loss of
        email. Therefore, you should always have more than one name server
        configured for your domain, preferably on different networks. See TE.4
      Warning: all specified name servers are on sub-net
        It is advisable to have at least one name server on a different network;
        when one network is unavailable, the other name servers will continue to serve
        the world. See TE.4
    * primary name server ""
      Error: specified name server is not listed as NS record.
        All public name servers for a domain must also be listed as NS records
        in the zone of the domain. This domain was specified explicitly
        as a name server, but not found in the zone description of the primary
        name server. TE.6a
      Error: name server is not listed in your zone.
        The specified name server could not be found in your zone file. It should
        be listed as an A or AAAA record.
      Warning: "" not defined.
        The external view of the domain does not list "localhost". That is not
        a problem, as long as the internal view on the domain has it defined.
        If you do not use DNS views, you may consider this to be an error.	86400	IN	SOA
                                            (2007091301 8H 2H 7D 1D) 
      Error: the MNAME in SOA says "" is the primary name server.
        The MNAME field in the SOA record (first parameter) lists a different
        primary name server from the one specified for this check. RFC1035
        section 3.3.13	86400	IN	NS
      Warning: hidden name server "" never used for first contact.
        The zone contains an NS record for a host which is not in the list of
        specified name servers. Hence, this name server will not be used to
        initiate contact to the domain. It may be used in sequential lookups,
        so it may still be useful.
    * secondary name server "" [BROKEN] [HIDDEN]
      Broken: name server "" not found in your zone.
        The name server does not resolve in an A or AAAA record in the
        checked zone.

    Please help !
  2. falko

    falko Super Moderator ISPConfig Developer

    You must use an FQDN (such as for NS and SOA records, not an IP address.

Share This Page