Configuring mail from remote domain

Discussion in 'Installation/Configuration' started by kropcik, Mar 26, 2014.

  1. kropcik

    kropcik New Member

    Hello. I need a little help with configuring/forwarding dns records for mail server.

    I have bought a domain (mydomain.lt) from remote providers (hostex.lt), and I've launched ispconfig on centos 6.5 on my machine.

    I have created mailboxes, mail server is working, squirellmail too, but i cant get/send mail. What should i configure to create mailboxes and make that clients could create it too for their subdomains (client.mydomain.lt) ?

    Should I create some dns zones records in my own machine, or just forward some dns'es from domain provider control panel to get it working ?

    Thank you very much.
     
  2. srijan

    srijan New Member HowtoForge Supporter

    Hi

    which guide you have used for configuration?For mail get/send part please paste the mail.log.

    You need add the DNS record from DNS-add-wizard in ISPConfig admin interface.

    Br//
    Srijan
     
  3. kropcik

    kropcik New Member

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You seem to use the dns server of your hosting provider, in that case, you do not have to add a dns record in ispconfig.

    Go to the "DNS Zona" tab in the settings of your provider and check that you have a-records for the zone and the www subdomain that point to the ip address of your server and that you have a mx record, that points to one of the a-records or the hostname of your server.
     
  5. kropcik

    kropcik New Member

    My DNS Zona at domain provider:
    [​IMG]

    My ispconfig (Email->Domain):
    [​IMG]

    My ispconfig (Email->Email mailbox)
    [​IMG]

    Still no luck with sending/getting email.
    Here is the maillog after i sended email from squirrellmail:
    Code:
    Mar 26 11:49:50 localhost amavis[13741]: (13741-05) Passed CLEAN {RelayedOpenRelay}, [88.119.198.151] <info@esolution.lt> -> <esolution@postbox.lt>, Message-ID: <5c4b65fa2f2c6545bc7b0e519f8ecd6f.squirrel@esolution.lt>, mail_id: 1l1Bk-PdC_-D, Hits: -0.001, size: 645, queued_as: 0A1F82EEE2, 7184 ms
    Mar 26 11:49:50 localhost postfix/smtp[26804]: CCD9E2EF00: to=<esolution@postbox.lt>, relay=127.0.0.1[127.0.0.1]:10024, delay=7.3, delays=0.09/0.01/0/7.2, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 0A1F82EEE2)
    But im not getting emails from outside, and none gets from me.
     
  6. srijan

    srijan New Member HowtoForge Supporter

    Do you use a dynamic IP?
    If yes then
    Most dynamic IP addresses are blacklisted nowadays (see link ) so that's most likely the reason why you can't send emails. To overcome this, you can relay your emails through another mailserver: here

    Br//
    Srijan
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The mx record is wrong. MY records point to a domain or subdomain, and not to a IP. Edit the mx record and replace the IP address with "esolution.lt."
     
  8. kropcik

    kropcik New Member

    Thank you very much.
     
  9. kropcik

    kropcik New Member

    Thank you too for the information. I think i will use another smtp server.
     

Share This Page