configuring IPTABLES firewall

Discussion in 'HOWTO-Related Questions' started by adityavpratap, May 25, 2006.

  1. adityavpratap

    adityavpratap New Member

    Hi,
    I am running Slackware 10.1 kernel 2.6.16.
    I followed the instructions given in the following link -
    http://www.howtoforge.net/custom_iptables_firewall
    however with the modifications relevant to Slackware.
    Now when I run the rc.firewall script I get the following error message -
    the /etc/firewall/firewall.conf.iptables file is missing. Have I missed something or there should be a default file somwhere?
    Any suggestions?
     
  2. falko

    falko Super Moderator

  3. adityavpratap

    adityavpratap New Member

    Hi,
    Thanks for the prompt reply,
    I tried the link mentioned in your reply and put the firewall.conf.iptables file in /etc/firewall/
    Now when I run the firewall I get the following rather lengthy output on the console -
    Being a complete newbie in this particular area, I am at loss to know what is going on. I hope you can throw some light on this.
     
  4. falko

    falko Super Moderator

    Did you save firewall.conf.iptables with Unix linebreaks or with Windows linebreaks? You must save it with Unix linebreaks.
     
  5. adityavpratap

    adityavpratap New Member

    Yes. It is saved with Unix linebreaks.
     
  6. falko

    falko Super Moderator

    What's in firewall.conf.iptables?
     
  7. adityavpratap

    adityavpratap New Member

    Here is the file -
     
  8. falko

    falko Super Moderator

  9. adityavpratap

    adityavpratap New Member

    Thanks falko, for the prompt reply. However, I found the link mentioned by you already and have recompiled the kernel with the said parameter = y. Still the error messages ceases to go away.
    I don't know what is going on.
    By the way, I have no chkconfig in slackware. But even then the firewall should start, and this is not happening.
     
  10. falko

    falko Super Moderator

    And you booted the correct kernel, and not the old one?
     

Share This Page