Configure OpenNMS Step By Step

Discussion in 'HOWTO-Related Questions' started by PortMan, Aug 2, 2006.

  1. PortMan

    PortMan New Member

    I'm looking at this tutorial and have a question about the presteps:
    It says:
    Before you start OpenNMS installation, you need to install following packages:

    tomcat 4.*
    postgres 8.*

    I'm using FC5 and have no idea how to install these packages. Can someone help?
  2. falko

    falko Super Moderator ISPConfig Developer

    You can search for the packages, like this:
    yum search postgres
    If you've found the package, install it like this:
    yum install [I]package_name[/I]
  3. PortMan

    PortMan New Member

    Thanks falco.

    I did a yum search jdk* and below is what came up. Which one should I install on FC5?

    [[email protected] ~]# yum search jdk*
    Loading "installonlyn" plugin
    Searching Packages:
    Setting up repositories
    core                                                                 [1/3]
    extras                                                               [2/3]
    updates                                                              [3/3]
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    cryptix.noarch                           3.2.0-4jpp_3fc         core
    Matched from:
    Cryptix 3 is a cleanroom implementation of Sun's Java Cryptography
    Extensions (JCE) version 1.1. In addition to that it contains the
    Cryptix Provider which delivers a wide range of algorithms and support
    for PGP 2.x. Cryptix 3 runs on both JDK 1.1 and JDK 1.2 (Java 2).
    mockobjects-jdk1.4.noarch                0.09-12jpp_4fc         core
    Matched from:
    MockObjects for 1.4 JDK
    MockObjects specific to JDK 1.4.x
    mockobjects-alt-jdk1.4.noarch            0.09-12jpp_4fc         core
    Matched from:
    Mockable API for JDK 1.4
    Alternative API for JDK 1.4 to allow for testing
    ldapjdk.noarch                           4.17-1jpp_3fc.1.1      core
    Matched from:
    ldapjdk-javadoc.noarch                   4.17-1jpp_3fc.1.1      core
    Matched from:
    Javadoc for ldapjdk
    Javadoc for ldapjdk
  4. falko

    falko Super Moderator ISPConfig Developer

    It seems as if none of these packages is the right one... Unfortunately I didn't write that tutorial so I can'T tell you more. Maybe you have to use third-party repositories that have the right packages? Like the Dag Wieers repository:

Share This Page