configuration issues

Discussion in 'Installation/Configuration' started by mattmatt, Aug 21, 2013.

  1. mattmatt

    mattmatt New Member

    Hi there!

    I've recently set up a VPS running Debian Wheezy LAMP for my site, and decided to include mail as well. Being my first time attempting a mail server, I tried following a tutorial for setting up Postfix and Courier, but I was having issues configuring courier and virtual mailboxes.

    So anyway, while I was searching for solutions, I came across ISPConfig and decided to give it a go. It seemed to have installed alright, but I was getting 403 errors "You don't have permission to access / on this server."
    After digging around I noticed that ISPConfig was installed in /var/www yet I've set my apache root to /home/matt/www

    So I chowned www-data /var/www/ispconfig and symlinked it to /home/matt/www, but I was still receiving 403's. After checking apache's error.log, I noticed a bunch of "Permission denied in /usr/local/ispconfig/interface/*/*.php"

    I was eventually able to log into by running chown -R www-data:ispconfig on both /var/www/ispconfig and /usr/local/ispconfig/interface/ still gives me 403's though. Is running it the way I am okay?

    Any assistance getting it to run as it's intended(if necessary) would be greatly appreciated!


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which of the perfect setup guides did you fllow to prepare your server for the installation of ispconfig? If your server was lready configured with a website or you used another guide that was not made for ispconfig, then its unliklely that you can install ispconfig on your server without a complete reinstall of the system and then follow the perfect setup tutorial.

    ISPConfig us installed in /usr/local/ispconfig/.The path /var/www/ispconfig is a symlink which exists for downward compatibility and is not used anymore in current versions.

    This was not a good idea as this destroyed the ispconfig permissions and opened your system for possible hacks. You should uninstall ispconfig with the uninstall.php in the ispconfig install flder and then reinstall it.

    You can not access ispconfig with a path like, ispconfig has its own vhost and listens on port 8080.

    No, thats not ok.
  3. mattmatt

    mattmatt New Member

    Apache, MySQL and PHP had already been set up. So I followed but at the end, I couldn't log into squirrelmail. This was a week and a half ago, so I forget what the exact issues were, but from the errors and posts found online I gathered it had to do with virtual users, which is when I came across mention of ISPConfig.

    So I followed but since I already had apache, postfix and courier etc setup, I skipped to page 5 and installed ISPConfig as per the instructions.

    Since your response, I have now removed the symlinks /home/matt/www/ispconfig and /var/www/ispconfig and cp -pr'ed the backup I made of /usr/local/ispconfig/interface
    So I the configuration and permissions should be as they were when initially installed.

    You said that it may be unlikely I'll be able to install ISPConfig without a complete reinstall of the system, which unfortunately isn't an option. So since all I really want is a working mail system where I can add mail accounts like, admin, postmaster and [email protected] etc and allow them to log into a web interface like sqirrelmail to send/receive email, should I uninstall ISPConfig and try again?


  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Skipping parts of the guide is the most likely reason that your system does not work now.

    Thats not easy to decide as your syste is quite messed up by following 2 incompatible guides and one even partly.

    the most liely way to repair the setup is by using the virtual user guide and uninstall all components described there so you get a cleaner system. Then uninstall ispconfig by using its uninstall script. Then do all steps of this guide starting from step 7 until you install ispconfig.
  5. mattmatt

    mattmatt New Member

    Okay thanks, I'll give that a go.

Share This Page