configuration after installation? I'm lost!

Discussion in 'Installation/Configuration' started by AL-Kateb, Feb 8, 2010.

  1. AL-Kateb

    AL-Kateb New Member

    Hello everybody!
    i followed the instructions in

    i have installed CentOS 5.4 on virtual box for testing purposes and followed all the instructions in that how to.
    the only thing is! i was searching for how to configure ispconfig after installation but i could not find it anywhere!

    i am able to access it but the problem is whenever i add anything (ftp user, ssh user) or anything at all it's just not being added! like it is listed there in the ispconfig panel but i try loging in using that username or password and it does not work! i am sure i missed something important in here but i'm not sure what that is

    after installation i tried adding new client then i added website for that client ... i went ot hosts file in C:\Windows\System32\drivers\etc and edited it to have this domain i created point to my virtual machine!

    everything is working fine and even domains are pointing to where they should

    but whenever i create ftp user for instance i just cannot login with that username

    and one more thing! i have named installed but still monitor keeps telling me myDNS-server offline!

    i would really appreciate someone pointing me to the right direction providing a how to link or tutorial or anything that can help me set this up correctly

    thanks in advance
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look into the ispconfig monitor if there are any errors in the system log and check if the jobqueue is empty.
  3. AL-Kateb

    AL-Kateb New Member

    the jobqueue is empty and everything looks ok in the system .. there are irrelevant errors though

    the thing it says about ftp is ftp session started and ftp session ended and that's all.

    i looked at etc/passwd and it has tow accounts that looks to be added by ispconfig (web1, web2) though i did not name the ftp user web1 nor web2.
    but anyway! i am not even able to open ftp using my root account?? i thought proftpd by default is going to use the system accounts for authentication?
    the seems i need to configure proftpd to make it uses the system accounts?
    how am i gonna do that anyway : )

    i will google it but any help u can give her guys is appreciated
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You use proftpd? proftpd is not even supported by ispconfig 3. No wonder that you can not login. ISPConfig 3 uses pure-ftpd with mysql bindings and not /etc/passwd bindings. Please make sure that you installed your server exactly as described in the perfect setup guide.
  5. AL-Kateb

    AL-Kateb New Member

    i followed the instructions as they are in the how to article.
    it says on page 6 to install proftpd : ) i did not know it's not compatible with ispconfig! though the author of the article should have mentioned so

    i will remove proftpd and install pure-ftpd
    and the same about myDNS-server

    then i will see what do i get : )
  6. AL-Kateb

    AL-Kateb New Member

    he even says this:
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Ispconfig 2 and 3 are completely different software packages which have different software requirements. What you did is that you used a guide for ispconfig 2 and then installed ispconfig 3 on it.

Share This Page