config error with suPHP

Discussion in 'ISPConfig 3 Priority Support' started by jpcyrenne, Sep 12, 2014.

  1. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Good Day (once again),

    I'm installing the Perfect Centos 6.5 server for the latest ISPConfig.

    # cat /etc/redhat-release
    CentOS release 6.5 (Final) (actually upgrated from a 6.2 - yum upgrade)

    I'm installing like usual? For the first time i get this error with the suPHP config file:
    cd /tmp
    tar xvfz suphp-0.7.1.tar.gz
    cd suphp-0.7.1/
    ./configure --prefix=/usr --sysconfdir=/etc --with-apr=/usr/bin/apr-1-config --with-apxs=/usr/sbin/apxs --with-apache-user=apache --with-setid-mode=owner --with-php=/usr/bin/php-cgi --with-logfile=/var/log/httpd/suphp_log --enable-SUPHP_USE_USERGROUP=yes

    checking for APR... configure: error: the --with-apr parameter is incorrect. It must specify an install prefix, a
    build directory, or an apr-config file.

    # make
    make: *** No targets specified and no makefile found. Stop.

    I took a chance and installed : yum install apr (it installed well, but still the same error.

    Am I just missing a simlink somewhere?

    Also, I see there is a newer version of suPHP (suphp-0.7.1.tar.gz). I tried it and it didn't work (Warnings and missing files )
    configure: WARNING: unrecognized options: --with-php, --enable-SUPHP_USE_USERGROUP
    configure: error: cannot find install-sh,, or shtool in config "."/config

    - Will you have a procedure out for CentOS 7 soon? I noticed the commands have changed alot. (Apache changes some configs, no more netstat (use ss now)...)

    - I might move to Debian for the next one... Is PHP higher than 5.3 on the latest Debian install?

    Thank You,

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I recommend that you go trough the centos 6.5 perfect server guide and rerun allinstall commands to ensure that nothing is missing I installed a server for a customer last week by using the guide above on centos 6.5 and it worked out of the box, so the instructions should be working.

    There are still packages mising from epel. We still check their repository regularily but sadly they have not added all packages yet.

    The default php vrsion is 5.4.x and there are all php versions between 5.3.0 and 5.6 available for Debian, so its up to you which php versions you want to use for your sites. You can also use these simultaniously, so your server can have php 5.3, 5.4, 5.5 and 5.6 installed and you choose the latest supported version for each website individually.

Share This Page