Concerns connection via SSH

Discussion in 'ISPConfig 3 Priority Support' started by misterm, May 21, 2015.

  1. misterm

    misterm Member

    hello
    Bug in the version in which ISPConfig was updated when creating a user for an ssh connection:
    Logically, we create user unless I am mistaken access to all the website directory
    Well no, I create the user, and I connect, I see nothing.
    I look at my file "/ etc / passwd" and I notice, and after creating the user, I found this in my "passwd" file:
    Bug or no bug, if I am right course ...

    Mz
    :)
     
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Short answer: No bug.
    You aren't using jailed ssh users so this is the correct home dir of the user.
     
    misterm likes this.
  3. misterm

    misterm Member

    hello
    We will say that I never use this method, since using the panel and it is the first time I get an error as I just report it.
    I use Debian Jessie 8
    Voila
    Mz
     
  4. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    When you connect to a non-jailed user, you see the home dir of that user, of course. You have to cd ../../ to see the web.
     
  5. misterm

    misterm Member

    We will say that this is of no matter what, we'll say a first

    I have not this error in Wheezy

    whether

    Mz
     
  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Maybe you tested it with the previous ISPConfig version, which had a different home directory for non-jailed users.
     
  7. misterm

    misterm Member

    No I think not, because I am on the right version, and I'm on the things I say

    Mz
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Thst no bug, this cange is intended. The non jailed ssh user was mising a home directory in prior versions, in 3.0.5.4p5 the non jailed user has now the same home directory path then the jailed ones. (/home/username inside the web root)
     
    misterm likes this.
  9. misterm

    misterm Member

    Till, let's not get excited, and I have to apologize because what I say Croydon, I do.
    BUT, before the update, I did not have this kind of error.
    I create my user, and after he had access to the site directory, without making changes in ISPConfig.
    Till I say, I have not the error in Wheezy, you believe me as well ...
    Mz
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats neither an error nor a bug, I explained that the new behaviour is intended. It was changed as the old behaviour caused problems: the user ended up in the web root instead of their own home directory and the web root is not writable by the user. See release notes of the p6 release, the change is listed in the changelog incl. description why this change was nescessary and which bug was fixed by implementing this change.
     
  11. misterm

    misterm Member

    Security question this change?
    if it is that, for the next version, foresee a drop-down fields:
    admin
    user
    Hey bé, we must not be "delayed" to understand that we returned 2 times backward, before arriving in the correct folder, frankly
    Ok
    What I know now
    Till thank you

    Mz ;) :)
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

  13. misterm

    misterm Member

    Stop Till
    you stop, you're right
    Stop

    :)
     

Share This Page