composer error

Discussion in 'Programming/Scripts' started by Tom John, Mar 27, 2020.

  1. Tom John

    Tom John Member HowtoForge Supporter

    Hi guys,
    i installed composer to my htdocs folder and when i want to create a project with
    Code:
    php composer.phar create-project --prefer-dist cakephp/app [app_name]
    
    i get the following error:
    Code:
    Problem 1
        - cakephp/cakephp 4.0.4 requires ext-intl * -> the requested PHP extension 
    
    in php.ini i enabled intl already but i get the same error.
    2. Problem:
    when i create a project with cakephp i get the following error when i open the project in the browser
    Code:
    Warning: require(/opt/lampp/htdocs/patientcare/vendor/autoload.php): failed to open stream: No such file or directory in /opt/lampp/htdocs/patientcare/webroot/index.php on line 31
    
    Fatal error: require(): Failed opening required '/opt/lampp/htdocs/patientcare/vendor/autoload.php' (include_path='.:/opt/lampp/lib/php') in /opt/lampp/htdocs/patientcare/webroot/index.php on line 31
    
    Can anyone help me with these issues?
    thanks a lot for your kind help
     
  2. Tom John

    Tom John Member HowtoForge Supporter

    i found the error....
    i need to install php intl
    sudo apt-get install php-intl
     
    till likes this.

Share This Page