Completely disable a module

Discussion in 'Installation/Configuration' started by wwweiss, Dec 27, 2021.

  1. wwweiss

    wwweiss Member HowtoForge Supporter

    I installed a new multiserver system and I am doing the final configurations. Here I want to completely disable the "Support"-Module, but I could not find an option in the server configuration. I looked to /usr/local/ispconfig/interface/lib/config.inc.php and saw that I can add a config.inc.local.php.
    I did this and put these lines inside that file (on the panel-server):
    Code:
    $conf['modules_available'] = 'dashboard,admin,mail,sites,monitor,client,dns';
    $conf['interface_modules_enabled'] = 'dashboard,mail,sites,dns,tools';
    But this did not change anything. Any ideas?
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Did you add these lines or did you change the existing lines?
     
  3. wwweiss

    wwweiss Member HowtoForge Supporter

    I created the new file /usr/local/ispconfig/interface/lib/config.inc.local.php and added these two lines to that file. Nothing else is in this file.
    Also I tried to modify the lines inside config.inc.php (just to see what happens), but also no change in the web UI.
    Is this related to the multiserver setup? Are there additional files involved?
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Are you editing the file on the server that hosts the panel?
     
  5. wwweiss

    wwweiss Member HowtoForge Supporter

    Yes. I have panel, web1, web2, mail and webmail (no DNS, because I do not need these). I made the changes only on panel. I also made a reboot of the panel server after the changes were saved.
    When I look to the folder I also see a config.inc.php~
    Is this a normal situation? This file has similar content like config.inc.php but is missing the include line for config.inc.local.php. I just think that ISPConfig is using this file and not config.inc.php. Should I just delete this file?
     
  6. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    A reboot is not needed. The file with ~ at the end is a auto-save by your editor usually. You can delete it.
     
  7. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Be sure to include an opening <?php tag.

    Did you logout and login again after your changes?
     
  8. wwweiss

    wwweiss Member HowtoForge Supporter

    The opening tag is there (I am a PHP developper).
    The file with the ~ is not from my side. This was created during installation with the autoinstaller (it is available on all servers). Seems someone on your side left this inside ;-)
    I made some more tests. And added one more line below the two lines to set the language
    Code:
    $conf['language'] = 'fr';
    Changing this value between en, de, fr always works fine. This means the file itself is working.
    So I assume that setting the value of "modules_available" and/or "interface_modules_enabled" just gets overwritten by another function.
    In the UI I found that I can set the modules when logged in as admin (System -> CP users). Here I unchecked "Help" for the reseller. Seems that this is the solution. On all clients assigned to the reseller the option "help" is still checked, but when logged in as client the support module is not visible - which was my primary intention.
    Is this setting ok or wil it be overwritten by updates or any other changes in the system?
    Just asking due to the warning about not to change anything in this section.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    That's fine to change it there.
     
  10. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Hm, not sure, but it could be that setting this is only applied to new users, and not to existing clients/resellers/admins.
     
  11. wwweiss

    wwweiss Member HowtoForge Supporter

    Ah, you are right. Just tested it. I set the value for 'interface_modules_enabled' leaving out "help" im my config.inc.local.php. Then added a new reseller. This resller has not enabled the Support-Module.
    So after many posts here, I can say: everything is working as expected - but it only works for new users (which of course makes sense). Existing users can be modified in the UI Sytem -> CP users.
    Thanks all for your help!!
     
    Th0m and till like this.

Share This Page