Complete and utter meltdown

Discussion in 'Installation/Configuration' started by jopa123, Sep 2, 2010.

  1. jopa123

    jopa123 New Member

    After several weeks of running well, my Ubuntu (10.04, I think)/ISPConfig3 box has totally crapped out on me.

    A little background. I would be considered a Linux newb even though this is the 3rd time I have attempted to learn a little about Linux through building an ISPconfig box. Maybe it is beyond me. I consider myself pretty literate on most computer issues (in a Windows environment, obviously)

    I followed the perfect setup for Ubuntu/ISPConfig 3 and all was well. After not logging in for a few days the box seemed to run slowly. I rebooted it through a command line (Telnet) and then it didn't respond.

    I hooked it up to a monitor and keyboard/mouse and booted it again. I got some sort of busybox/intrafms message. I read up on this and found that holding the shift key would get me into grub. I attempted to alter the Grub menu but the edits would not stick.

    After more research I tried to update (or was it re-install?) Grub. This seemed to work but on reboot I got a Grub prompt.

    Then I booted to Live CD and tried to fix it that way. However, when I mount the partition with the boot folder and try to apply any of the suggested fixes, the system does not seem to recognize that the partition was mounted. I got:

    "cannot find a device for / (is /dev mounted?)"

    I think this may be a permissions problem (I was using "sudo") because I noticed that there was no grub.cfg file in the boot/grub folder (it is Grub2 - there is no menu.lst file either) but there was a "grub" folder outside the "boot" folder (maybe from my attempt to update grub?) This folder had a grub.cfg file and when I try to copy it into the grub/boot folder it told me I didn't have permission.

    I ran "sudo mount /dev/sda1 mnt" and tried again but it didn't seem to help.

    Do I need to wipe the drive and start again? I sure hope not. Any help is greatly appreciated. I apologize if my rant is incoherent
     
  2. Mark_NL

    Mark_NL New Member

    What was the error you got right before you entered busybox?
     
  3. jopa123

    jopa123 New Member

    Mark,

    I'm sorry. I didn't write it down. I didn't actually enter Busybox, it just booted to it.

    I believe the error had something to do with the device not being readable. Then it kicked to intramfs.
     
  4. Mark_NL

    Mark_NL New Member

    luckily a server has only one device in it ;-)

    please be more specific with your error messages, we can't start guessing here ;-)
     
  5. jopa123

    jopa123 New Member

    Unknow error

    Mark,

    I appreciate the help.

    I'm sorry but I tried to fix this mess without bothering the community, hoping to learn more Linux in the process. It's been 3 days since I've seen the message and I did not write it down. I had Googled the error message when it came up and just tried searching my Google search history to find the exact message, but it is not available.

    I can get to the Grub prompt, or boot from Live CD, is there a way to view a log history or something that might tell us the error message?
     
  6. jopa123

    jopa123 New Member

    Anyone?

    I've got a long weekend coming up. Is it worth trying to investigate this or should I wipe it and try again.

    Or should I give up until I'm better versed in Linux?

    Thanks
     
  7. falko

    falko Super Moderator ISPConfig Developer

    What's your partitioning scheme? Do you have just one large / partition, or do you have multiple partitions? If the latter, did you mount all partitions (including /)?
     
  8. jopa123

    jopa123 New Member

    I followed the perfect setup

    The disk utility shows 3 "volumes"

    1) 255MB Ext2 (boot partition ?) /dev/sda1 Bootable
    2) 100GB "Container for logical partitions" /dev/sda2
    3) 100GB extended LVM2 physical volume /devsda5

    Looking at this something seems wrong, since it is only a 100GB drive. Am I reading this incorrectly?

    Under "places" it only shows sda1 available to mount. Using a terminal, I tried to mount sda5 like this:

    sudo mount /dev/sda5 mnt

    I got this error message = unknown filetype

    Also tried:

    sudo mount /dev mnt

    It says I need to specify the filetype

    and

    sudo mount /dev/ /media

    says that the mount point /media does not exist
     
    Last edited: Sep 4, 2010
  9. jopa123

    jopa123 New Member

    Rhozillez. Please don't use my command line entries. I'm new here, too.
     
  10. jopa123

    jopa123 New Member

    I guess I'll start over

    Unless someone has a suggestion, I guess I'll start from scratch again.

    Thank you for the help, anyways.
     

Share This Page