Compiz startup on user login (CentOS) question...

Discussion in 'HOWTO-Related Questions' started by Bailx, Jun 24, 2010.

  1. Bailx

    Bailx New Member

    I was using the Beryl HOWTO as a guide for starting Compiz on CentOS 5.5 and just had a few questions...

    First of all I installed Compiz from this page and everything works fine, I can run it fine from the start menu shortcut or by typing fusion-icon. For whatever reason compiz --replace does not work for me, but you don't get the icon that method anyways...

    So I was using the Beryl scripts as a template, and used the following code:

    sleep 4
    exec gnome-session
    [Desktop Entry]
    All I get is a black screen and all I can do is ctrl+alt F5 and get back to a terminal...where I usually just reboot to get a fresh start....

    I tried putting the fusion-icon line at the bottom with a 10 second sleep time above it, but it does nothing that way (just normal desktop)....

    like this: (not sure why this couldn't work)

    exec gnome-session
    sleep 10
    So, I was just wondering if anyone had any different things I could try as I'm kind of lost as what to do next.... I've tried rc.local and even made rc.d scripts to no avail (runlevel 5).... although I can see why those methods would not work.... i still wanted to try it....

    Thanks for any help....

    (PS- I did install Beryl successfully yesterday and it started automatically with those scipts, but I'd rather use Compiz-Fusion as it's much more stable, as it should be I suppose)....this testing was done on a clean install with no remnants of Beryl..... (32-bit)
    Last edited: Jun 24, 2010
  2. Bailx

    Bailx New Member

    Seems like there is no real fix for this, you just have to set it on a per-user basis in the sessions menu (startup apps)...

    Not the most elegant solution, but whatever... it works

    Last edited: Jul 1, 2010

Share This Page