compiling the 2.6.27.6 kernel on debian--the os is stuck on the"waiting for root file

Discussion in 'Kernel Questions' started by p2pover, Nov 28, 2008.

  1. p2pover

    p2pover New Member

    hi dears: here is my problem
    the section of the kernel compile
    1 cd /usr/src tar the kernel-2.6.27.6 package
    2 cd linux-2.6.27.6
    3 make clean && make mrproper
    4 cp /boot/config-2.6.18.6-686 ./.config
    5 make menuconfig (during the step I tried the old .config with no changes, also tried SATA drivers .....)
    (PS: when I loaded the old kernel's .config,it displays "config:3157 warning:symbol value 'm'invalid for RTC-INTF-..")
    6 make-kpkg clean
    7 fakeroot make-kpkg --initrd --append-to-version=-new kernel_image kernel_headers
    8 cd /usr/src
    9 dpkg -i ***kernel-image-**deb
    dpkg -i ***kernel-headers-**.deb
    10 reboot

    And then the os was stucked on "waiting for root file system " after about 10 minutes,on the display it shows:
    Warning bootdevice maybe renamed TRY root=/dev/had11
    Gave up waiting for root device. Common problems:
    -boot args(cat /proc/cmdline)
    -check rootdelay=(did the system wait long enough)
    - check root=(did the system wait for the right device)
    -Missing modules (cat /proc/modules;ls /dev)

    Alert /dev/sda11 doesn't exist Dropping to a shell
    /bin/sh :can't access tty, job control turned off


    at the end here is my menu.lst:
    title Debian Gun/linux kernel 2.6.27.6-new ##the compiled new kernel
    root (hd0.8)
    kernel /vmlinuz-2.6.27.6-new root=/dev/sda11 ro
    intrd /intrd/img-2.6.27.6-new
    save defalut

    title Debian Gun/Linux kernel 2.6.18-6-686 ##the old kernel
    root (hd0,8)
    kernel /vimlinuz-2.6.18-6-686 root=/dev/sda11 ro
    initrd /initrd.img-2.6.18-6-686
    save default

    /etc/fstab´╝Ü
    filesystem mount point type options dump pass
    proc /proc proc default 0 0
    /dev/sda11 / ext3 default,errors=remount-ro 0 0
    /dev/sda9 /boot ext3 default 0 2
    /dev/sda10 none swap sw 0 0


    I've tried many times and several days ,the same problem appeared , I really
    don't know where the problem come from , Please help me , thank you all very much !!
    //BOW
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You can try to create a new initrd:
    Code:
    mkinitrd -v -f /boot/intrd/img-2.6.27.6-new 2.6.27.6-new
     
  3. ibf756

    ibf756 New Member

    Do you have any sort of rescue disk you can boot the machine with to mount your file systems and fix the problem?
    It looks as though you are trying to boot from a seperate partition than your root partition. What partition is the new kernel image stored on? You will probably need to boot the machine somehow, mount your file system and edit menu.lst so that the bootloader is no longer confused when you try to boot.
     

Share This Page