Compiling and rebooting kernel (debian etch)

Discussion in 'Kernel Questions' started by cassel, Dec 26, 2006.

  1. cassel

    cassel New Member

    Hey guys,
    I tried to compile kernel following this instruction and everything went fine with compiling, installing, but, as you can guess, I got problem trying to boot into new kernel... I got message: "Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)". And it's kind a strange, cause I compiled kernel with my working .config file, didn't touch any point, just loaded, and compiled... So can anybody help me with this? Kernel 2.6.19, the reason, why I'm trying to recompile kernel is my wireless card, it's problematic for me to get it working..
    Thanks in advance;)
  2. New Member

    Do you have a package similar as initrd.img in the directory where the new kernel is sitting after compiling? If not, try to produce it. You can have a look at "How to compile the kernel-the ubuntu way". I think it will give you some clues.

    Well, I also got the message:"Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)" while booting my new kernel. You see I want to custom my little linux that has a minimal kernel, a minimal busybox embedded in the rootfs. I call my linux as magicbox.I hope the magicbox can work on a piece o f floppy disk or usb disk. I made the rootfs with busybox as ramdisk image. My kernel boots well with the old initrd.img.So I think there maybe something wrong with my ramdisk image or I have lost something that initializes the hardware before installing the ramdisk image. I want to attach my ramdisk image here, but don't know how.

    Any suggestion or informtion is greately appreciated

    Last edited: Dec 26, 2006
  3. cassel

    cassel New Member

    Yep, I have that.. Still no luck..
  4. falko

    falko Super Moderator ISPConfig Developer

  5. cassel

    cassel New Member

    Thanks Falko, I did everything according your instructions and it worked:) but what about ipw3945 (intel pro wireless) module? is it possible to compile into kernel? cause I don't find it in vanilla kernel. Maybe there is some patches.. just I don't know how to operate with patches:) And one more question, can I apply existing kernel configuration to newer kernel, lets say from 2.6.8-3 to 2.6.9-1 ?
  6. falko

    falko Super Moderator ISPConfig Developer

    If there are patches for it, then you can compile it into the kernel. The tutorial shows how to patch the kernel sources. :)

    Yes, that should work.

Share This Page