Compile A Kernel - The Ubuntu Way

Discussion in 'Kernel Questions' started by alagup, May 30, 2007.

  1. alagup

    alagup New Member

    Hello,

    I am a brand new Linux user. I am installing Ubuntu 6.10 on my PC
    using VMware. I am following the instructions on your page
    http://www.howtoforge.com/kernel_compilation_ubuntu.

    I did the following:
    $sudo rm -f /bin/sh
    $sudo ln -s /bin/bash /bin/sh
    $sudo apt-get update

    It worked fine until this point. When I use the command below

    $sudo apt-get install kernel-package libncurses5-dev fakeroot wget
    bzip2

    in the end I get the message E: Could't find package vget.

    Did I miss anything? Could someone please help. I despretly need to
    install the kernel by today. Thank you. Appreciate any help I can get.

    rgds,
    Alagu
     
  2. volksman

    volksman New Member

    according to the error you posted you must have typed vget instead of wget on the previous line:

    Could't find package vget.

    the package is called 'wget'
     
  3. alagup

    alagup New Member

    Compilation problems

    Hi Volksman,

    Thank you for your help. It worked. I downloaded the kernel. Now I am trying to configure and build.

    Since this is the first time I am installing Linux I did not do the step

    $sudo cp /boot/config-`uname -r` ./.config

    I did $ sudo make menuconfig

    choose "Load an Alternate Configuration File" and left the field blank and hit exit.

    Now when I try to build $sudo make-kpkg clean I get a lot of error messages.
    These are some of the messages:
    make[2] *** [silentoldconfig] Error1
    make[1] *** [silentoldconfig] Error2

    you have not yet configured your old kernel! Please run some configurator.

    When I run make config should I not leave it blank. Please advice. Thank you.

    Alagu
     
  4. alagup

    alagup New Member

    One more error message

    One more thing. When I do

    $sudo cp /boot/config-`uname -r` ./.config

    I get the msg: /boot/config-`uname -r: No such file or directory.

    I am under the directory /usr/src/linux

    Thank you.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    That's the problem. You already have a working kernel (otherise you couldn't work on your Ubuntu system ;) ), so you should use that kernels configuration for your new kernel. Please try to follow the howto as close as possible.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    uname -r
    and
    Code:
    ls -l /boot
    ?
     

Share This Page