Communication problem

Discussion in 'General' started by muekno, Nov 16, 2014.

  1. muekno

    muekno Member HowtoForge Supporter

    Did set up new multiserver system opensuse on 13.1 Master Server web as webserver with apache slave server mail with apache, dovcot postfix squirrelmail
    Did installation with ispconfig 3.0.5.4p1. Did not configure more than a domain. all seem well, jobqueue empty. The I realized p4 und did update slave first.
    configured am mail_box, job queue will not empty, monitor says no service is running on slave, while service status on slavecommandline says all are running.
    I can login on slave to mysql well. I can telnet vom slave to mysql on master port 3306. Searching for solution since yesterday afternoon. No idea left.
    Please help
    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    use the mysql command, run it on the slave server and use the exact dbmaster details (hostname, username and password) from /usr/local/ispconfig/server/lib/config.inc.php file of that slave server to connect to the master. Thats the only reliable way to test that the connection really works. In most cases the hostname settings in /etc/hosts are causing the connection problems.
     
  3. muekno

    muekno Member HowtoForge Supporter

    login to Master from Slave with data from config.inc.php on command lie works.
    "#mysql --host=host.domain.de --user=ispcsrv2 --password=password dbispconfig" works fine. /etc/hosts double checked on master and slave

    Any other Idea

    Rainer
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. muekno

    muekno Member HowtoForge Supporter

    Master Server WEB Results
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.0.5.4p5


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.4.20

    ##### PORT CHECK #####

    [WARN] Port 143 (IMAP server) seems NOT to be listening
    [WARN] Port 993 (IMAP server SSL) seems NOT to be listening
    [WARN] Port 110 (POP3 server) seems NOT to be listening
    [WARN] Port 995 (POP3 server SSL) seems NOT to be listening
    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening

    ##### MAIL SERVER CHECK #####

    [WARN] I found no "submission" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.
    [WARN] I found no "smtps" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.

    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Unknown process (httpd2-prefor) (PID 24277)
    [INFO] I found the following mail server(s):
    Postfix (PID 1460)
    [WARN] I could not determine which pop3 server is running.
    [WARN] I could not determine which imap server is running.
    [INFO] I found the following ftp server(s):
    PureFTP (PID 975)

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [anywhere]:21 (975/pure-ftpd)
    [anywhere]:22 (1000/sshd)
    [localhost]:25 (1460/master)
    [localhost]:9000 (1097/php-fpm.conf))
    *:*:*:*::*:8080 (24277/httpd2-prefor)
    *:*:*:*::*:80 (24277/httpd2-prefor)
    *:*:*:*::*:8081 (24277/httpd2-prefor)
    *:*:*:*::*:21 (975/pure-ftpd)
    *:*:*:*::*:22 (1000/sshd)
    *:*:*:*::*:25 (1460/master)
    *:*:*:*::*:443 (24277/httpd2-prefor)
    *:*:*:*::*:3306 (1345/mysqld)




    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination


    Slave Server MAIL results

    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.0.5.4p5


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.4.20

    ##### PORT CHECK #####

    [WARN] Port 8080 (ISPConfig) seems NOT to be listening
    [WARN] Port 8081 (ISPConfig Apps) seems NOT to be listening
    [WARN] Port 443 (Webserver SSL) seems NOT to be listening
    [WARN] Port 993 (IMAP server SSL) seems NOT to be listening
    [WARN] Port 995 (POP3 server SSL) seems NOT to be listening
    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening
    [WARN] Port 21 (FTP server) seems NOT to be listening

    ##### MAIL SERVER CHECK #####

    [WARN] I found no "submission" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.
    [WARN] I found no "smtps" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.

    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Unknown process (httpd2-prefork) (PID 5020)
    [INFO] I found the following mail server(s):
    Postfix (PID 1431)
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 969)
    [INFO] I found the following imap server(s):
    Dovecot (PID 969)
    [WARN] I could not determine which ftp server is running.

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [anywhere]:110 (969/dovecot)
    [anywhere]:143 (969/dovecot)
    [anywhere]:22 (986/sshd)
    [anywhere]:25 (1431/master)
    [localhost]:10025 (1431/master)
    [localhost]10 (969/dovecot)
    [localhost]43 (969/dovecot)
    *:*:*:*::*:80 (5020/httpd2-prefork)
    *:*:*:*::*:22 (986/sshd)
    *:*:*:*::*:25 (1431/master)
    *:*:*:*::*:3306 (1315/mysqld)




    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
     
  6. muekno

    muekno Member HowtoForge Supporter

    P.s.

    I said Yes to backup while going from p1 to p4. As it ist not yes a production system, there will be no problem going bach. Need a shot explanation or link

    Otherweise would be interesting what went wrong

    Rainer
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The debug instructions aew in the last part of the post I mentioned.
     
  8. muekno

    muekno Member HowtoForge Supporter

    Still same problem, Output on slave
    /usr/local/ispconfig/server/server.sh
    16.11.2014-22:36 - ERROR - Replication failed. Error: (mail_user) in MySQL server: (localhost) Incorrect date value: '' for column 'last_quota_notification' at row 1 # SQL: REPLACE INTO mail_user (`mailuser_id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_id`,`email`,`login`,`password`,`name`,`uid`,`gid`,`maildir`,`quota`,`cc`,`homedir`,`autoresponder`,`autoresponder_start_date`,`autoresponder_end_date`,`autoresponder_subject`,`autoresponder_text`,`move_junk`,`custom_mailfilter`,`postfix`,`access`,`disableimap`,`disablepop3`,`disabledeliver`,`disablesmtp`,`disablesieve`,`disablesieve-filter`,`disablelda`,`disablelmtp`,`disabledoveadm`,`last_quota_notification`,`backup_interval`,`backup_copies`) VALUES ('1','1','2','riud','riud','','2','isa@isabelle-mk.de','isa@isabelle-mk.de','$1$SQn/YqIe$PzveF0xy9QdjJScIQmpdk1','isabelle','5000','5000','/var/vmail/isabelle-mk.de/isa','0','','/var/vmail','n','0000-00-00 00:00:00','0000-00-00 00:00:00','Out of office reply','','n','','y','y','n','n','n','n','n','n','n','n','n','','none','1')
    16.11.2014-22:36 - ERROR - Error in Replication, changes were not processed.
    finished.

    Output on master just finished


    servers are time synchronised via NTP from local NTP source, double checked
     
  9. srijan

    srijan New Member HowtoForge Supporter

    Check this error report
    Post your master.cf
     
  10. muekno

    muekno Member HowtoForge Supporter

    I know Postfix, Dovecot etc. are not yet fully configured.
    The problem ist that the synchronisation does not work. Otherwise the Monitor shows FTP-Server: Offline
    SMTP-Server: Online
    POP3-Server: Online
    IMAP-Server: Online
    mySQL-Server: Online
    on the slave, whats definitly not true. There ist no FTP configured, but MySQL Postfix and Dovecot are running. So this says to me there are no or wrong information sent from slave to master

    Rainer
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats the reason for your problem.

    Whoch operatng system do you sue on master and slave and whch mysql version is used on master and slave?
    Did you update the master and the slave server to 3.0.5.4p5? Replication errors happen mostly when master and slave dont run the same ispconfig version.
     
  12. muekno

    muekno Member HowtoForge Supporter

    Did the following
    "show fields from mail_user;" on both servers, the schemas are identical.
    "select * from mail_user;" on both servers, both report empty
    Job queue still shows me
    2014-11-16 11:04 mail1.gerdakloos.de Delete mail_user
    2014-11-15 17:24 mail1.gerdakloos.de Insert mail_user
    /usr/local/ispconfig/server/server.sh still shows the same error.
    I think it would be the best to go back to p1 by useing the backup made while updateing.
    need information whow

    Rainer
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem would have occurred with p1 as well. So you can go back off course, but this wont solve your issue. What about he other questions I asked?
     
  14. muekno

    muekno Member HowtoForge Supporter

    as I wrote OS openSUSE 13.1 installed from same ISO the same afternoon, after step 1 to 6 "zypper up" both server are on the same code base and same latest patch level so should be on equal mysql version. Setup of master an slave was with 3.0.5.4p1. Then updated to 3.0.5.4.p5, slave first, then the Problem starts.
    as I said, I answered "yes" to the backup question on both servers while updating, so it should be possible do go back to 3.0.5.4.p1. What I want to save is the work to do a complete new setup of the servers. As I said too, there ist nearly nothing configured on Users, Domains, Mailboxes etc., so even going back to step 6 on both server would be worst.

    Rainer
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    mysql --version

    on both servers and post the output.

    Then take a look athe the mysql my.cnf files and search for the line "sql_mode=" and post that line.
     
  16. muekno

    muekno Member HowtoForge Supporter

    on master "mysql Ver 14.14 Distrib 5.6.12, for Linux (i686) using EditLine wrapper"
    sql_mode=NO_ENGINE_SUBSTITUTION

    on slave "mysql Ver 14.14 Distrib 5.6.12, for Linux (i686) using EditLine wrapper"

    sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES

    Rainer
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    ok, thats the problem. you missed to set the sql mode on the slave. Please set it to:

    sql_mode=NO_ENGINE_SUBSTITUTION

    and restart mysql.
     
  18. muekno

    muekno Member HowtoForge Supporter

    changed the mode as you probosed. Restarted both mysql services, still same problem
    /usr/local/ispconfig/server/server.sh reports same error on slave


    Rainer
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    Login to ispconfig, go to monitor > system log and delete the error message to confirm that ispconfig shall proceedwith the processing on the slave.
     
  20. muekno

    muekno Member HowtoForge Supporter

    deletet the error, job queue will not empty, server.sh on slave reproduces the error and does a new entry in system log. A it is a replace command it must go wrong as the table is empty. Whow can I delete the faulty command or step forward

    Rainer
     

Share This Page