Common FTP problem that I can't seem to solve

Discussion in 'Installation/Configuration' started by andysm849, Oct 2, 2008.

  1. andysm849

    andysm849 New Member

    I installed ISPconfig and proftpd and both appear to be working. But like I have found others have experienced, even though the service of proftpd successfully starts, ISPConfig sees it as offline. I have tried to follow things that have worked for other people with not a whole lot of success because I really don't know much about hostnames specifically.

    I have fedora core 9. And after every change I tried, I restarted proftpd and then refreshed the page to see if ISPconfig recognized it, which it hasn't. My firewall has port 21 unblocked. I don't get any error messages (just OK's) when restarting proftpd.

    Here is my proftpd.conf:

    # This is the ProFTPD configuration file
    ServerName			"home-server"
    ServerIdent			on "FTP Server ready."
    ServerAdmin			[email protected]
    ServerType			standalone
    #ServerType			inetd
    DefaultServer			on
    AccessGrantMsg			"User %u logged in."
    #DisplayConnect			/etc/ftpissue
    #DisplayLogin			/etc/ftpmotd
    #DisplayGoAway			/etc/ftpgoaway
    DeferWelcome			off
    SocketBindTight 		on
    # Use this to excude users from the chroot
    DefaultRoot			~ !adm
    # Use pam to authenticate (default) and be authoritative
    AuthPAMConfig			proftpd
    AuthOrder			mod_auth_pam.c* mod_auth_unix.c
    # Do not perform ident nor DNS lookups (hangs when the port is filtered)
    IdentLookups			off
    UseReverseDNS			off
    # Port 21 is the standard FTP port.
    Port				21
    # Umask 022 is a good standard umask to prevent new dirs and files
    # from being group and world writable.
    Umask				022
    # Default to show dot files in directory listings
    ListOptions			"-a"
    # See Configuration.html for these (here are the default values)
    #MultilineRFC2228		off
    #RootLogin			off
    #LoginPasswordPrompt		on
    #MaxLoginAttempts		3
    #MaxClientsPerHost		none
    #AllowForeignAddress		off	# For FXP
    # Allow to resume not only the downloads but the uploads too
    AllowRetrieveRestart		on
    AllowStoreRestart		on
    # To prevent DoS attacks, set the maximum number of child processes
    # to 30.  If you need to allow more than 30 concurrent connections
    # at once, simply increase this value.  Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    MaxInstances			20
    # Set the user and group that the server normally runs at.
    User				nobody
    Group				nobody
    # Disable sendfile by default since it breaks displaying the download speeds in
    # ftptop and ftpwho
    UseSendfile			no
    # This is where we want to put the pid file
    ScoreboardFile			/var/run/proftpd.score
    # Normally, we want users to do a few things.
      AllowOverwrite		yes
      <Limit ALL SITE_CHMOD>
    # Define the log formats
    LogFormat			default	"%h %l %u %t \"%r\" %s %b"
    LogFormat			auth	"%v [%P] %h %t \"%r\" %s"
    everything after that is commented out so I assume its not important to include here.

    The "netstat -tap | grep ftp" command results in:

    (Not all processes could be identified, non-owned process info
     will not be shown, you would have to be root to see it all.)
    tcp        0      0 home-server:ftp            *:*                         LISTEN      -       

    My /etc/hosts file looks like this:

    # Do not remove the following line, or various programs
    # that require network functionality will fail.		localhost.localdomain localhost localhost
    ::1		localhost6.localdomain6 localhost6 home-server
    I'm pretty sure its just an error with me naming things the wrong thing or something like that, but like I said I'm not too experienced with what all these hostname things are...
  2. andysm849

    andysm849 New Member

    I tried reinsalling proftpd and it was a success but once again I have the same problem. If you dont know whats wrong could some one point me a good tutorial about this stuff so I can debug it myself?
  3. falko

    falko Super Moderator ISPConfig Developer

  4. andysm849

    andysm849 New Member

    Thanks for that suggestion. I actually didnt try that.

    Unfortunatly though after trying it now it still didn't fix anything. Any other tips?
  5. falko

    falko Super Moderator ISPConfig Developer

    Please modify /etc/hosts as follows:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.		localhost.localdomain localhost localhost home-server
    ::1		localhost6.localdomain6 localhost6
    and restart Proftpd. What does
    netstat -tap
    show then?
  6. andysm849

    andysm849 New Member

    You are a life saver, falko. proftpd was recognized and everything works now. Thanks for taking the time to help me.

Share This Page