Combining Tutorials

Discussion in 'HOWTO-Related Questions' started by Asharru, Sep 28, 2010.

  1. Asharru

    Asharru New Member

    I have followed the guides for:
    'The Perfect Server - Ubuntu Lucid Lynx (Ubuntu 10.04) [ISPConfig 2]'
    'Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 10.04)'

    However I am having problems getting PHPMYADMIN page to load (doesn't seem to have installed anywhere I can find it), and trying to log into Squirrelmail tells me that the username/password is wrong (the virtual mail folders are not being created in /home/vmail), etc.

    Instead of trying to troubleshoot the separate issues, would it be possible to get a tutorial that combines the two above (without ISPConfig and DNS server)?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    If you don't need ISPConfig, then just follow the second tutorial (Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 10.04)).
     
  3. Asharru

    Asharru New Member

    I had tried that four or five times before trying the Perfect Server guide. But just in case, I blew away the partitions, redid the "Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 10.04)" and yet again I get "Connection dropped by IMAP server" and there is nothing in /home/vmail after sending a test email using mailx. From what I have seen on the forums here and searching on Google, this is a common issue, but none of the suggested resolutions seems to correct the issue.

    What should I try next?:confused:
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please take a look into the log file /var/log/mail.log and post the error messages that you get there when you try to send a email to a local mailbox.
     
  5. Asharru

    Asharru New Member

    Code:
    Sep 29 10:57:27 optimus postfix/pickup[18938]: 82581280D7A: uid=0 from=<root>
    Sep 29 10:57:27 optimus postfix/cleanup[19036]: 82581280D7A: message-id=<20100929175727.82581280D7A@asharru.net>
    Sep 29 10:57:27 optimus postfix/qmgr[18425]: 82581280D7A: from=<root@asharru.net>, size=337, nrcpt=1 (queue active)
    Sep 29 10:57:38 optimus postfix/smtpd[19046]: connect from localhost[127.0.0.1]
    Sep 29 10:57:38 optimus postfix/trivial-rewrite[19039]: warning: do not list domain asharru.net in BOTH mydestination and virtual_mailbox_domains
    Sep 29 10:57:38 optimus postfix/trivial-rewrite[19039]: warning: do not list domain asharru.net in BOTH mydestination and virtual_mailbox_domains
    Sep 29 10:57:38 optimus postfix/smtpd[19046]: A14B0280D60: client=localhost[127.0.0.1]
    Sep 29 10:57:38 optimus postfix/cleanup[19036]: A14B0280D60: message-id=<20100929175727.82581280D7A@asharru.net>
    Sep 29 10:57:38 optimus postfix/qmgr[18425]: A14B0280D60: from=<root@asharru.net>, size=765, nrcpt=1 (queue active)
    Sep 29 10:57:38 optimus postfix/trivial-rewrite[19039]: warning: do not list domain asharru.net in BOTH mydestination and virtual_mailbox_domains
    Sep 29 10:57:38 optimus amavis[16630]: (16630-03) Passed CLEAN, <root@asharru.net> -> <asharru@asharru.net>, Message-ID: <20100929175727.82581280D7A@asharru.net>, mail_id: fDeA46b+pHRJ, Hits: -0.001, size: 337, queued_as: A14B0280D60, 11111 ms
    Sep 29 10:57:38 optimus postfix/smtpd[19046]: disconnect from localhost[127.0.0.1]
    Sep 29 10:57:38 optimus postfix/smtp[19040]: 82581280D7A: to=<asharru@asharru.net>, relay=127.0.0.1[127.0.0.1]:10024, delay=11, delays=0.17/0.02/0.01/11, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=16630-03, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as A14B0280D60)
    Sep 29 10:57:38 optimus postfix/qmgr[18425]: 82581280D7A: removed
    Sep 29 10:57:38 optimus postfix/local[19047]: A14B0280D60: to=<asharru@asharru.net>, relay=local, delay=0.17, delays=0.08/0.03/0/0.07, dsn=2.0.0, status=sent (delivered to mailbox)
    Sep 29 10:57:38 optimus postfix/qmgr[18425]: A14B0280D60: removed
    
    And when I next login, the system tells me :"You have new mail in /var/mail/asharru"
    It should be creating it in the virtual mail folder in /home/vmail though
     
    Last edited: Sep 30, 2010
  6. Asharru

    Asharru New Member

    Okay, got it. Took the domain name out of "mydestinations" in /etc/postfix/main.cf and restarted postfix. Folders are being created now.
     

Share This Page