ColdFusion 8 with ISPConfig

Discussion in 'General' started by tristanlee85, Nov 3, 2007.

  1. tristanlee85

    tristanlee85 New Member

    When installing ColdFusion 8 and configuring it with the Apache server, is there anything specific I have to do to get it to work with my sites under ISPConfig? I think the only question I had that may have caused a problem with be when it asked me where the DocumentRoot was for the Apache server. I went with the default /var/www/html/.
  2. edge

    edge Active Member Moderator

    I've still got CFMX7 on my Debian servers, and they all point to /var/www/html
    I'm sure that the new 8 version will be the same.
  3. tristanlee85

    tristanlee85 New Member

    I haven't been able to get it on my ISPConfig server yet. I configured it to work with Apache, and I created a simple test page:

    <head><title>Hello World</title></head>
    <cfoutput>#ucase("hello world")#</cfoutput>
    and that displays, but how can I get to the administration part of ColdFusion with the way ISPConfig is setup? Before I would type: http://localhost:8500/CFIDE/administrator/index.cfm and I would get there, but since I'm not running the ColdFusion server as a standalone, I have to work around how ISPConfig does the documents folder.
  4. edge

    edge Active Member Moderator

    I found some old notes that I used to install CFMX7 on my Debian Sarge server.

    I've NOT installed the new 8 version till now, so I do not know if this will still work.

    Anyway. This is what I used to install
    After all this you will need to run the "connector" script that will add stuff to the Apache configuration (in /etc/httpd/conf).

    I access the admin like this: http://my_domain/CFIDE/administrator

    Anyway.. When I did the upgrade from Debian Sarge to Etch, the CFMX7 server did not want to start anymore (some error about not being able to connect I think) Apache did also not want to start (it did not like all the stuff that was added by the coldfusion MX connector wizard)

    I needed to clean the Apache configuration file, and patch the CFMX7 install file, to make it work on the now updated Debian server(s).

    It was a pain in the a$$ as I could not find any info about installing CFMX7 on Debian Etch (now you can)

    If I have some time tomorrow, I might give the new 8 version a go on one of my Virtual systems.
  5. tristanlee85

    tristanlee85 New Member

    Well I got it to work. Don't ask me now. Before I was getting JRun Servlet erros, but now it's trying to work.

    Originally, CFIDE was installed in /var/www/html/. In ISPConfig, I created a new site that I will use to configure different parts of the server. I tried to copy CFIDE from the original directory to /home/www/ and I'm getting errors that it can't find files.

     The web site you are accessing has experienced an unexpected error.
    Please contact the website administrator.
    The following information is meant for the website developer for debugging purposes.
    Error Occurred While Processing Request
    Could not find the ColdFusion Component or Interface
    Ensure that the name is correct and that the component or interface exists.
        * Enable Robust Exception Information to provide greater detail about the source of errors. In the Administrator, click Debugging & Logging > Debug Output Settings, and select the Robust Exception Information option.
        * Check the ColdFusion documentation to verify that you are using the correct syntax.
        * Search the Knowledge Base to find a solution to your problem.
    Browser   	Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20070224 Firefox/
    Remote Address
    Date/Time   	03-Nov-07 06:58 PM
    Is there a configuration file that I can go into and change the path from /var/www/html/ to my new directory? I figure that's my only problem and I'll have it all worked out.

Share This Page