Cockpit / NetworkManager / systemd-networkd

Discussion in 'General' started by TonyG, Jan 12, 2021 at 9:00 PM.

  1. TonyG

    TonyG Active Member

    The Cockpit server monitor presents views of network, CPU, RAM, updates available, and other metrics. It uses the running network manager for its reporting. There has been an ongoing issue with Debian and Ubuntu where the software updates page displays error "Cannot refresh cache whilst offline". There is a discussion about this in the Github Cockpit repo. systemd-networkd is the default manager and manages the interfaces that are available. The issue is that NM is running but has nothing to do, so it reports itself as offline, and somehow that result is captured rather than anything that systemd-networkd has to offer. So result is that their software updates page is showing an error.

    The accepted solution is to disable NetworkManager. If it's not active+offline then Cockpit doesn't report an error. But there is a side-effect to that. Without NM the Cockpit Network page is empty. So a follow-on solution is to disable the default systemd-networkd and actually use NM with a change to /etc/netplan/50-cloud-init.yaml.

    Ultimately my questions here are : Does ISPConfig care which interface manager is being used? If we switch to NM, is there anything that needs to be done with ISPConfig to avoid issues?

    At this moment I have not done my homework to research NM or systemd-networkd. It's just been out of my scope of required reading until now. So I don't know if there is some obvious "best" solution for interface management or if ISPConfig does anything anymore with this. I recall discussions about special considerations for eth0, etc. but that doesn't apply here.

    Does anyone here have additional insight into this issue so that we can get all environments working harmoniously?

    Thanks!
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Nope, it's completely "unaware" of network config.
    No, just ensure the "Network Configuration" checkbox is off in Server Config (that's the one where ISPConfig will try to configure eth0, which is almost never what you want nowadays).
     
    TonyG likes this.

Share This Page