Co-domain problem

Discussion in 'General' started by Gimly, Dec 20, 2007.

  1. Gimly

    Gimly Member

    Hi all,

    I have a problem with co-domain. The forward doesn't work. For example : I created forum.espace4you.org on co-domain to forward on my directory forum (www.espace4you.org/forum). But the server return :

    Code:
    Forbidden
    
    You don't have permission to access / on this server.
    
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    __________________________________________
    Apache Server at forum.espace4you.org Port 80
    I have debian etch with suphp & modsecurity enable on my server.

    Do you have any idea about this problem ? You can try it with the url.
    Thank you in advance for your answers. :)
     
  2. Hans

    Hans Moderator ISPConfig Developer

    When you created a co-domain, did you use "forum" within the hostname field and "espace4you.org" within the domain field? Within the forward field you should add the text "http://www.espace4you.org/forum". Did you do that?
     
  3. Gimly

    Gimly Member

    It worked fine but I've upgrade ispconfig with 2.2.18 and now it doesn't work. The problem also exists for my customers. I don't modified settings on my server. If you have an idea ?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the vhost definition for this vhost from the file Vhost_ispconfig.conf
     
  5. Gimly

    Gimly Member

    I find the problem in the Vhost_ispconfig.conf, I add "/" on the vhost :

    But the problem is for all my vhost. There are a skeleton/template file in ispconfig, where I can add "/" for changing all my vhost and fix the bug ?

    Thank you for your answers
     
    Last edited: Dec 23, 2007
  6. falko

    falko Super Moderator ISPConfig Developer

    You can change this in the function make_vhost() in /root/ispconfig/scripts/lib/config.lib.php.
     
  7. Gimly

    Gimly Member

    Ok, Thank you now it work fine :)
     

Share This Page