Client Preview

Discussion in 'General' started by tyre, Sep 27, 2009.

  1. tyre

    tyre New Member

    Every other reference to this feature is linked to this post:

    However, I'm looking to deploy a public preview and have been 50% successful. What has worked thus far:

    I have that is a on the server and works as is.
    On my parent domain,, I setup a CNAME record that resolves to - and it works.

    But, where I run into conflict is where the domain is a legit domain not on my server (e.g. I'm developing a new site for a client, and their current live site is on another server; but i want to give them a preview and have it all ready and setup under their tld).

    I tried this demo by actually creating "" as a domain (which obviously I don't own) and then created the DNS entry CNAME subtest (thus, resolves to My thinking is that since there is a '' available locally, that it wouldn't bother to go find the real one. That isn't the case in practice.

    Any ideas of how I can improve this? Am i going about this the right way?
  2. Mccy_McFlinn

    Mccy_McFlinn New Member

    Maybe I'm missing a trick here, but all you need do is add a new host header (alias) to the sites-available config file.

    [Using your example domains]So if you have setup on your ISPConfig then go to the apache config file for and add the alias That way anyone going to will go to the site you've setup on your ISPConfig server.

    I apologise if I'm heading in the wrong direction on this one. If so set me straight and I'll see if I can advise from there.

  3. tyre

    tyre New Member

    you're heading in the correct direction, but it doesn't work like that unfortunately. (and you can add server aliases via ispconfig, instead of editing the vhost files, btw) These scenarios work: is a domain that works on the server (i.e. resolves to the correct IP and runs one of the sites). I setup an alias... (whos nameserver is pointed to the server) - this works with no DNS modifiations. is a domain that works on the server as before. I setup a DNS entry for (the main domain of the server) for to point to as a cname entry. This also works.

    But say I have setup (which i do have setup currently)... setting up aliases doesn't work at all. Setting up a dns entry to point to internally doesn't work - it only displays

    It seems like if the DNS locally says "hey, has a site here" that it would find it and work. I'm no expert, hence this post, so I invite anyone with additional understanding other than my own to please help out.

    Perhaps I need to edit things manually outside of ispconfig? i'm using mydns, fwiw..
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Create a DNS A-Record that points to the IP address of the server for the domain that yiu use for testing instead of a cname. Then add this test domain or subdomain as alias to the website. There has nothing to be edited outside of ispconfig of course.
  5. tyre

    tyre New Member


    When I made as a site, I also added as a dns record, creating:

    Code:   IN  A
    www                IN  A
    mail                 IN  A  IN MX  IN NS  IN NS
    (not sure if thats how it gets written, but that's what's in ispconfig)

    so now that I have as a "working" site on the server, creating an alias domain such as "" doesn't work.

    I tried a cname because that worked for another site that's working.. is working as is, and i setup domainC CNAME in my dns record. But that aproach doesn't work with the above example :(

    am i missing something there?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely, your server is not the authoritive DNS server for, so adding it to your dns server is simply ignored by your browser.

    You have to be the owner of the domain that you add and you have to go to the domain registry were you registered the domain name and set your nameserver as the primary nameserver of the domain. then you have to wait up to 48 hours until the changes in the dns system are changed in all caching nameservers worldwide.

Share This Page