Client log unmounted

Discussion in 'Installation/Configuration' started by oufcomm, Apr 3, 2014.

  1. oufcomm

    oufcomm New Member

    Hello, i have a problem : when i changed a website name, i got errors of system logs.

    i checked the log files in the client/log and all folder is empty. I tried to create error.log, acces.log without success.

    So i do 'df -h' :
    df: «*/var/www/clients/client24/web62/log (deleted)*»: Aucun fichier ou dossier de ce type
    I understand that the file system of the log folder is unmounted.

    i tried
    mount /var/www/clients/client24/web62/log
    without success !

    This file is well in the fstab.
    How can i remount this log system file or relink it ? Thanks in advance.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    apache logs to /var/log/ispconfig/httpd/domain.tld and not the mountpoint /var/www/clients/client24/web62/log, so you can not get errors in the logs even if no bind mount is active. The only thing that happens if a mountpoint is mising is that your customers can not download the log files by ftp anymore.

    So if you got any errors in the apache logs, then thats not related to the mountpoints. If you want to ensure that all bind mounts are applied when your users can not access a log by ftp, then run:

    mount -a

    to activate them again.
  3. oufcomm

    oufcomm New Member

    Thanks Till,

    Yes, i saw that logs are in /var/log/ispconfig/httpd/

    Logs for my client are readable in /var/log/ispconfig/httpd/ No problem.
    So, there is an error in bind to /var/www/clients/client24/web62/log.

    I tested mount -a :
    mount: Aucun fichier ou dossier de ce type
    (neither file or folder of this type)

    I don't understand why 'mount -a' don't work, because fstab contains :
    /var/log/ispconfig/httpd/ /var/www/clients/client24/web62/log none bind,nobootwait 0 0

    I managed the server, my clients can't access to log. So it's not a real problem.
    But logs of Cron ISPC in the dashboard display tones of error about this file which is not readable.
    It's the reason i try to solve this :p

    Any ideas?
    Last edited: Apr 3, 2014
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    and the directory /var/www/clients/client24/web62/log really exists?
  5. oufcomm

    oufcomm New Member

    Yes !! Like /var/www/

    Logs of this website are only on /var/log/ispconfig/httpd/
  6. oufcomm

    oufcomm New Member

    I've solved my problem.

    What i have done :
    # umount /var/www/

    Then :
    # mount -a

    And then :
    # ln -s /var/www/ /var/www/clients/client24/web62/log/

    Thanks Till.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please be aware that the symlink will not work for jailed ssh users, so your users will not be able to access the logs. thats why ispconfig uses bind mounts and not symlinks.
  8. oufcomm

    oufcomm New Member

    Yes Till, i read that somewhere.
    In my case, my clients can't access there logs, only me.
    So i accept this poor hack.

Share This Page