Client has a mail authentication problem

Discussion in 'Installation/Configuration' started by chancer, Sep 18, 2007.

  1. chancer

    chancer New Member

    I just talked a client through setting up their email client (Thunderbird) so I know it's set up correctly. They have never yet successfully connected to the ISPConfig mail server, so each time they try "Get Mail" the response is "Please enter password", so I know that's OK and I checked the username with them at the same time, exactly as I've entered them in ISPC. dig -t mx gives a sensible response and their web site is working.

    The error response after clicking OK, having entered the password, is "Sending the password did not succeed. Mailserver responded: Login failed"

    I'm getting earache. Anyone got any balm to salve it? :p
  2. edge

    edge Active Member Moderator

    Did you client also enable "My server requires authentication"?
    I do not know where to look for this in Thunderbird, but in Outlook Express it's under the "servers" tab (at the bottom)

    Edit.. After looking at my setup, the info I gave you is for outgoing mail. So this is no good for you..
    Last edited: Sep 18, 2007
  3. catdude

    catdude ISPConfig Developer ISPConfig Developer

    Are you using [DOMAIN]_ as your User Prefix? Assuming you told the client to use "[email protected]" for his e-mail user name, try using "user_name%domain.tld". Some e-mail clients "help" users buy assuming that a user who enters his full e-mail address really meant to only enter the part before the "@" and strips off the part after.

    As an extra verification, have you tried making a telnet connection to port 110 and loggin in manually as that user, just to be sure that the user name and password you're working with really are correct?
  4. chancer

    chancer New Member

    As far as I can tell, it is not only for outgoing, it is a purely M$ device. It has 2 possible uses:

    1. If you're stuck on a IIS server. Cure: flog it and use the money to get anything which will run any other OS. Have a few beers with the excess.

    2. M$ sales hype. Ignore it. Buy some "yes, dears" with prezzies out of what you would have spent.

    In other words,no use.
  5. chancer

    chancer New Member

    I disabled automated prefixes for users. I couldn't see the point at the time, but that's another issue.

    What the software is doing vis-a-vis alias, @ and domain.tld is not relevant yet. We can't get as far as logging on, which just needs username and password.

    I'd love to try telnet. It's years since I have done and I can't work out the syntax now. I've been told by someone "who knows" that I shold ssh into the server first and use it from the cl. When I get there, I'm not sure what to type - been googling to get a clue.
  6. edge

    edge Active Member Moderator

    Telnet to hostname on port 25
    HELO your_domain_name or whatever
    MAIL FROM:[email protected]
    You type your message then CRLF period CRLF (ie, type a period on a line by itself then hit ENTER)
  7. catdude

    catdude ISPConfig Developer ISPConfig Developer

    Or to check POP access:

    telnet <serverip> 110
    +OK Hello there. <server sends this>
    user username
    +OK Password required. <server sends this>
    pass user's password/ib]

    If you have entered the user name and password correctly, you'll get:
    +OK logged in.
    If not, you'll get:
    -ERR Login failed.

    Either way, "quit" will disconnect you from the server.

    To test IMAP access:
    telnet <server ip> 143
    10 login (user name) (password)
    If you entered user name and password correctly, you'll get:
    10 OK LOGIN Ok.
    Otherwise you'll get:
    10 NO Login failed.

    Either way, entering:
    20 logout
    will disconnect you from the IMAP server.
  8. chancer

    chancer New Member

    Thanks once more, catdude. There is something wrong. I put in the password and the host returned -ERR Invalid command

    I went in to ISPConfig, re-entered the password correctly - I can't log in as the client because I have no idea what password the damned thing is holding for the client - and still couldn't get in via telnet.

    Am I right in thinking I can do it on the server command line as root with passwd username? Or has ISPconfig got its own system?
  9. chancer

    chancer New Member

    No, I entered it wrongly - didn't put pass first. Got in.

    So the problem isn't with u/n or pw, then. Any more ideas?

    <edit> In my browser, I am seeing this post before an earlier one - totally confusing! </edit>
    Last edited: Sep 18, 2007
  10. catdude

    catdude ISPConfig Developer ISPConfig Developer

    That suggests the problem is with the client setup. I believe you said he's running Thunderbird? In the left-hadn column of the TBird screen, click on the name of the e-mail account. In the box that opens up, click on Server Settings. In the "Server Name" box, specify your host name or IP address. In the "User Name" box, enter the user name you used in your telner testing. If that user name includes an "@", replace it with a "%". Click "OK", and you should then be able to fetch e-mail.

    At this point, if it still gives you a password error, make sure that you're really connecting to the server you think you are (i.e. if you've got "" in "Server Name", make sure that "dig" returns the IP address of your server).
  11. chancer

    chancer New Member

    Looks that way, doesn't it. dig and dig -t mx are giving perfect results. I use T'bird with several email accounts on one instance here, so I'll go through it again with them.

    Many tanks for both your practical help and your patinece, catdude. Stick around, I'll need some more! :)

Share This Page