Client cannot update DNS DKIM record

Discussion in 'General' started by hkendusers, Jul 9, 2019.

  1. hkendusers

    hkendusers New Member

    Hi all,

    If I login as "Client" user, create a DNS DKIM record, afterwards I found that there is "t=s;", and no "k=rsa;", this is not what I want. So I try to update it, but it prompts error "DKIM is not allowed. Use the DKIM button". If I click DKIM button, all fields are blank. So now I can't modify it anyway.

    Delete it and re-create is not an option for me, because creating DKIM record always add "t=s;" parameter, and I can't add "k=rsa;" .

    ISPConfig version: 3.1.14

    Please help.
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    This message shows up when you have added the domain in Email (ie. so ISPConfig is handling email for it), and have generate a DKIM key under the Email > Domain > DKIM (button). When ISPConfig handles email for the domain, a client is not allowed to create arbitrary nor multiple DKIM records. If it suites your purposes (ie. to set the DKIM keys for the standard ISPConfig hosted email+dns use case), you can change the DKIM keys under the Email tab.

    If that doesn't suite your needs, I know of two workarounds, the first is that an admin (not a client) can add new and change DKIM records by editing the TXT record directly (do not use the DKIM button); the second can be done by a client (with an admin's cooperation if using the domain control feature) though there's a small window to disrupt your email flow, which is to temporarily change the domain under the Email tab, make the required changes (to the correct domain name) in DNS, then change the Email domain back.

    I don't remember if there is a bug/feature request on this or not, but I don't find one in searching.

    FWIW, I tested (3.1.13+ git code, prior to 3.1.14 release).
     
  3. Jesse Norell

    Jesse Norell Well-Known Member

  4. hkendusers

    hkendusers New Member

    Thanks Jesse,

    In fact, there is no email server running, however it still prompts "DKIM is not allowed. Use the DKIM button" even no domain set in "Email" of ISPConfig and Mailserver is disabled in "Server Services" of ISPConfig. Is there something I have set wrongly?

    Currently I am using the first workaround that "admin" change DKIM records by TXT record. I hope this can be fixed soon :)
     
  5. Jesse Norell

    Jesse Norell Well-Known Member

    Perhaps the behavior changed in 3.1.14, as I was able to use the DKIM button for arbitrary/multiple dkim records in 3.1.13, even as a client.
     
  6. hkendusers

    hkendusers New Member

    Oh, sorry that I might not describe clearly.

    There is no problem to use DKIM button for multiple DKIM records, I just click the TXT record to update it, then it prompts "DKIM is not allowed. Use the DKIM button" even no domain set in "Email" of ISPConfig and Mailserver is disabled in "Server Services" of ISPConfig.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

  8. Jesse Norell

    Jesse Norell Well-Known Member

    The workaround should be to just delete the old record, then add the updated version again with the dkim button.
     
  9. hkendusers

    hkendusers New Member

    Jesse:
    Delete and add again cannot help because DKIM always add "t=s;" parameter that I want to delete, secondly user can't add "k=rsa;" in client level, both require admin level to update via editing TXT

    Till,
    Thanks for adding a feature request, is it possible that also allow editing t=s; & k=rsa; ?
     

Share This Page