Client can recieve mail but not send emails.

Discussion in 'Installation/Configuration' started by Appie Thrasher, Apr 12, 2008.

  1. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    Hello all,
    Again a problem with my server. The situation is like this:

    I have setup my own server here at home. Its in my home network. I used the perfect setup with Ubuntu 7.10.
    I have setup an domain for our band with email users. I CAN sent and receive email without any problems all is working fine. So postfix is running nicely for me in my network at home.

    However if any of the other band members are trying to use their email, outside of my network, they can receive email but they cant sent any out.

    I have tryed it my self from outside my network and indeed its not sending emails out. I am getting the following error (in dutch)
    Het maken van een verbinding met de server
    is mislukt. Account ``server``protocol (:SMTP,poort : 25,beveiligd
    (ssl):nee, socketsfout,10060 foutnummer x800cccoe
    Rougly translated
     cannot connect to server. Account ``server``protocol (:SMTP,poort : 25,secured
    (ssl):NO, socketsfout,10060 foutnummer x800cccoe
    Yes authenticate smtp is enabled in outlook express. And is using the same as pop3.

    Must I forward some other ports in my router? I have forwarded the following
    80, 81, 25, 2525, 110, 20 and 21

    I am confused can someone point to the solution please.
  2. daveb

    daveb Member

  3. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter


    Thanks for thinking along with me. I know for a fact that my isp is blocking port 25. Thats why I forwarded port 2525 and I am using rollernet for relaying.

    I found in the provided link however one thing I am going to try I was using in the
    smtp      inet  n       -       -       -       -       smtpd
    2525      inet  n       -       n       -       -       smtpd
    That I have changed to
    smtp      inet  n       -       -       -       -       smtpd
    2525      inet  n       -       -       -       -       smtpd
    Like Falko suggested in that thread

    I must go to an outside connection however to know of its working.
    I will let you know
  4. daveb

    daveb Member

    Well looks like its working. just make sure you have them set their email clients to use port 2525.

    david@david:~$ telnet 2525
    Connected to
    Escape character is '^]'.
    220 ESMTP Postfix (Ubuntu)
    250-SIZE 10240000
    250 DSN
    221 2.0.0 Bye
    Connection closed by foreign host.
  5. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    I tested it today on an outside connexion and indeed its sending the mails.
    I think its okee now wil ask the other guys of the band to try it at their side.

    Will let you know what happens.

Share This Page