Clamdscan error 127

Discussion in 'Installation/Configuration' started by cnavarro, Sep 23, 2007.

  1. cnavarro

    cnavarro New Member

    I run ISPConfig on an Ubuntu Dapper machine using perfect setup.

    I had no issues until (like other forum members) large server loads and spam taking forever to scan was eating all the system resources, so I switched over to clamd per the instructions here on the forum. It worked fine, but I was getting notified that my version of clamd was old. I upgraded to the volatile version by adding this line to my sources.list:

    deb sarge/volatile main

    and running apt-get dist-upgrade

    This seemed to work, resolving the "out of date" message, but now my emails are not being successfully scanned. The following is from my mail headers:

    X-Virus-Status: Failed
    X-Virus-Report: /usr/bin/clamdscan error 127
    X-Virus-Checker-Version: clamassassin 1.2.4 with clamdscan /

    Everything else about the server seems to be functioning fine. I've searched this forum and googled until I'm blue in the face regarding error 127. I can't find a reference that will even tell me what it means.

    Any ideas where I can go from here?

    Christine Navarro
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    What happens if you run the command:


    manually on the shell?
  3. cnavarro

    cnavarro New Member

    Hi, Till

    Running /usr/bin/clamdscan, I get:

    -bash: /usr/bin/clamdscan: No such file or directory

    Clamdscan on my machine is located at:


    so I ran that instead and the result is:

    connect(): No such file or directory
    WARNING: Can't connect to clamd.

    ----------- SCAN SUMMARY -----------
    Infected files: 0
    Time: 0.191 sec (0 m 0 s)

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You must install clamd from your linux distribution as described in the clamd tutorial in the tipps & tricks forum. You can not use the ISPConfig clamdscan binary.
  5. cnavarro

    cnavarro New Member

    I haven't been able to locate the "clamd tutorial" in the tips & tricks forum. Could someone point me in the right direction? You were referring to the ISPConfig forum... right, Till?

  6. cnavarro

    cnavarro New Member

    Update: I obviously had inadvertently removed the clamd installation, while trying to remove clamscan (which was no longer being used). I still had to remove the bits of clamd that were left in order to successfully re-install. I commented out the volatile debian source in sources.list since I wasn't getting it to work properly. Since things appear to be working now, I'll just be satisfied with the out of date version of clamd. Better to be scanning with an old version than not at all.

    I was asked on reinstallation if I wanted to use the config files from the old installation, so I obviously hadn't removed everything... (I did not use --purge).

    I would support ISPConfig using clamd in the future or at least making it an option...

  7. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page