1. I had big trouble with my Postfix mail server and looked in the log and were not seeing any real problem then I remembered that clamd acted strange when I tried to install.

    My fix (makes me recive email :p):
    Please correct me if I are killing the system..

    yum reinstall amavisd-new spamassassin clamav clamd --disablerepo=epel
    sa-update
    chkconfig --levels 235 amavisd on
    # not chkconfig --del clamd
    # not chkconfig --levels 235 clamd.amavisd on
    chkconfig --levels 235 clamd on
    /usr/bin/freshclam
    /etc/init.d/amavisd start
    # not /etc/init.d/clamd.amavisd start
    /etc/init.d/clamd start

    Guide postfix on Centos 6.4 64:
    “yum install amavisd-new spamassassin clamav clamd unzip bzip2 unrar perl-DBD-mysql”
    or “yum install amavisd-new”

    Gives output

    Loaded plugins: fastestmirror, presto, priorities
    Loading mirror speeds from cached hostfile
    * base: archive.cs.uu.nl
    * epel: epel.mirror.nucleus.be
    * extras: archive.cs.uu.nl
    * rpmforge: archive.cs.uu.nl
    * updates: nl.mirror.eurid.eu
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package amavisd-new.x86_64 0:2.8.0-1.el6.rf will be updated
    ---> Package amavisd-new.noarch 0:2.8.0-4.el6 will be an update
    --> Processing Dependency: unzoo for package: amavisd-new-2.8.0-4.el6.noarch
    --> Processing Dependency: perl(Razor2::Client::Version) for package: amavisd-ne w-2.8.0-4.el6.noarch
    --> Processing Dependency: perl(Net::LDAP) for package: amavisd-new-2.8.0-4.el6. noarch
    --> Processing Dependency: perl(Mail::SPF) for package: amavisd-new-2.8.0-4.el6. noarch
    --> Processing Dependency: perl(DBD::SQLite) for package: amavisd-new-2.8.0-4.el 6.noarch
    --> Processing Dependency: perl(Authen::SASL) for package: amavisd-new-2.8.0-4.e l6.noarch
    --> Processing Dependency: p7zip-plugins for package: amavisd-new-2.8.0-4.el6.no arch
    --> Processing Dependency: lrzip for package: amavisd-new-2.8.0-4.el6.noarch
    --> Processing Dependency: /etc/clamd.d for package: amavisd-new-2.8.0-4.el6.noa rch
    --> Running transaction check
    ---> Package amavisd-new.noarch 0:2.8.0-4.el6 will be an update
    --> Processing Dependency: /etc/clamd.d for package: amavisd-new-2.8.0-4.el6.noa rch
    ---> Package lrzip.x86_64 0:0.614-1.el6 will be installed
    ---> Package p7zip-plugins.x86_64 0:9.20.1-2.el6 will be installed
    ---> Package perl-Authen-SASL.noarch 0:2.13-2.el6 will be installed
    --> Processing Dependency: perl(GSSAPI) for package: perl-Authen-SASL-2.13-2.el6 .noarch
    ---> Package perl-DBD-SQLite.x86_64 0:1.27-3.el6 will be installed
    ---> Package perl-LDAP.noarch 1:0.40-1.el6 will be installed
    --> Processing Dependency: perl(XML::SAX::Writer) for package: 1:perl-LDAP-0.40- 1.el6.noarch
    --> Processing Dependency: perl(XML::SAX::Base) for package: 1:perl-LDAP-0.40-1. el6.noarch
    --> Processing Dependency: perl(Convert::ASN1) for package: 1:perl-LDAP-0.40-1.e l6.noarch
    ---> Package perl-Mail-SPF.noarch 0:2.007-1.el6 will be installed
    ---> Package perl-Razor-Agent.x86_64 0:2.85-6.el6 will be installed
    ---> Package unzoo.x86_64 0:4.4-7.el6 will be installed
    --> Running transaction check
    ---> Package amavisd-new.noarch 0:2.8.0-4.el6 will be an update
    --> Processing Dependency: /etc/clamd.d for package: amavisd-new-2.8.0-4.el6.noa rch
    ---> Package perl-Convert-ASN1.noarch 0:0.22-1.el6 will be installed
    ---> Package perl-GSSAPI.x86_64 0:0.26-6.el6 will be installed
    ---> Package perl-XML-SAX-Base.noarch 0:1.04-1.el6.rf will be installed
    ---> Package perl-XML-SAX-Writer.noarch 0:0.50-8.el6 will be installed
    --> Processing Dependency: perl(XML::NamespaceSupport) for package: perl-XML-SAX -Writer-0.50-8.el6.noarch
    --> Processing Dependency: perl(XML::Filter::BufferText) for package: perl-XML-S AX-Writer-0.50-8.el6.noarch
    --> Processing Dependency: perl(Text::Iconv) for package: perl-XML-SAX-Writer-0. 50-8.el6.noarch
    --> Running transaction check
    ---> Package amavisd-new.noarch 0:2.8.0-4.el6 will be an update
    --> Processing Dependency: /etc/clamd.d for package: amavisd-new-2.8.0-4.el6.noa rch
    ---> Package perl-Text-Iconv.x86_64 0:1.7-6.el6 will be installed
    ---> Package perl-XML-Filter-BufferText.noarch 0:1.01-8.el6 will be installed
    ---> Package perl-XML-NamespaceSupport.noarch 0:1.10-3.el6 will be installed
    --> Processing Dependency: /etc/clamd.d for package: amavisd-new-2.8.0-4.el6.noa rch
    --> Finished Dependency Resolution
    Error: Package: amavisd-new-2.8.0-4.el6.noarch (epel)
    Requires: /etc/clamd.d
    Available: clamd-0.97.7-1.el6.x86_64 (epel)
    Not found
    Installed: clamd-0.97.7-1.el6.rf.x86_64 (@rpmforge)
    Not found
    Available: clamd-0.96.4-1.el6.rf.x86_64 (rpmforge)
    Not found
    Available: clamd-0.96.5-1.el6.rf.x86_64 (rpmforge)
    Not found
    Available: clamd-0.97-1.el6.rf.x86_64 (rpmforge)
    Not found
    Available: clamd-0.97.1-1.el6.rf.x86_64 (rpmforge)
    Not found
    Available: clamd-0.97.2-1.el6.rf.x86_64 (rpmforge)
    Not found
    Available: clamd-0.97.3-1.el6.rf.x86_64 (rpmforge)
    Not found
    Available: clamd-0.97.4-1.el6.rf.x86_64 (rpmforge)
    Not found
    Available: clamd-0.97.5-1.el6.rf.x86_64 (rpmforge)
    Not found
    Available: clamd-0.97.5-2.el6.rf.x86_64 (rpmforge)
    Not found
    Available: clamd-0.97.6-1.el6.rf.x86_64 (rpmforge)
    Not found
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
     

Share This Page