clamd, ispconfig, debian 6

Discussion in 'Server Operation' started by fxs, Jan 19, 2012.

  1. fxs

    fxs New Member

    The last update of ispconfig solve most of my problems.... Thanks
    I remind you: Server: i7 ssd ovh debian 6 Ispconfig 3.04.2
    Got this error messages:
    Perhaps it’s the same problem described in the following thread:
    Then I try
    [email protected]:~# service clamd status
    And get
    clamd: unrecognized service
    Then I try
    [email protected]:~# apt-get -u upgrade
    [email protected]:~# apt-get install clamav-daemon
    And get (in French!)
    This is a mixed of french and english I do not understand. Maybe it could say I want also 0.97.2+dfsg-1~squeeze1 but it's not there? But how to get precisely this package, what is the command?
    Why I cannot install clamd?
    What is your opinion regarding the error message?
    Thank you for your input.
    best regards
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/apt/sources.list?
  3. fxs

    fxs New Member


    This is:
    deb squeeze main
    deb-src squeeze main
    deb squeeze/updates main
    deb-src squeeze/updates main
    deb lenny/volatile main contrib non-$
    deb lenny/volatile main contrib non-$
  4. falko

    falko Super Moderator ISPConfig Developer

  5. fxs

    fxs New Member


    Thank you for your answer.
    Now it works!

    However, I have a second question.
    You have done a great tuto about munin and I have a problem (I’m dealing with debian 6 / ispcponfig 3.042).
    I did exactly what you wrote in this tuto. However, when the folder “monitoring” is inside a web site (handled by Ispconfig), munin cannot transfer the various files. When the folder "monitoring” is outside, it’s ok.
    [ERROR] Could not copy style.css from /etc/munin/templates to /var/www/
    I did chown rf munin:munin …., chmod 755 monitoring, etc.. but failed to solve this problem
    Inside the folder web, ls -l gives
    -rw-r--r-- 1 web2  client1 3062 15 déc.  02:01 courrier.htm
    drwxr-xr-x 2 web2  client1 4096 15 déc.  02:06 demo_img
    drwxr-xr-x 2 web2  client1 4096 14 déc.  15:59 error
    -rw-r--r-- 1 web2  client1 1861 22 janv. 13:55 index-bis.html
    -rwxr-xr-- 1 web2  client1 7007 15 déc.  02:04 index.html
    drwxr-xr-x 2 munin munin   4096 22 janv. 20:18 monitoring
    drwxr-xr-x 3 web2  client1 4096 15 déc.  02:05 p7epm
    drwxr-xr-x 3 web2  client1 4096 15 déc.  02:05 p7iq
    drwxr-xr-x 3 web2  client1 4096 15 déc.  02:01 p7iqm
    drwxr-xr-x 2 root  root    4096  2 janv. 00:30 stats
    notice: /var/www/
    I am unable to find the solution about these permissions. Any input will be appreciated.

    On the same subject, I would like the munin's graph not to be public. The solution of the tuto doesn't work for me. I copy the .htaccess from the folder stats (webalizer) to the folder monitoring. He works only one time and after that when we come back it is forbidden. I tried also the folder protection from ispconfig
    What is the best solution to reach the goal?

    best regards
  6. falko

    falko Super Moderator ISPConfig Developer

  7. fxs

    fxs New Member


    thanks for the prompt answer and your great help.

    I give a feedback.

    I follow your method and links. Then it gives me various error messages. One of these give me a clue: "Alias munin already created". So that I search..
    In the folder munin, there ise a file apache.conf with the code
    Alias /munin /var/cache/munin/www
    <Directory /var/cache/munin/www>
            Order allow,deny
            Allow from localhost ::1
            Options None
            # This file can be used as a .htaccess file, or a part of your apache
            # config file.
            # For the .htaccess file option to work the munin www directory
            # (/var/cache/munin/www) must have "AllowOverride all" or something
            # close to that set.
            # AuthUserFile /etc/munin/munin-htpasswd
            # AuthName "Munin"
            # AuthType Basic
            # require valid-user
            # This next part requires mod_expires to be enabled.
            # Set the default expiration time for files to 5 minutes 10 seconds from
            # their creation (modification) time.  There are probably new files by
            # that time.
        <IfModule mod_expires.c>
            ExpiresActive On
            ExpiresDefault M310
    hope that helps other people

    best regards

Share This Page